CVE-2026-104657
Last modified
CVE-2026-104657 is a high-severity vulnerability rated 7.5/10 on the CVSS scale. Missing integrity verification in the Progress Software Fiddler Download and Setup Skill on Linux, macOS, and Windows which allows an attacker to compromise or influence a release component and execute attacker-controlled code when a user runs the skill. On macOS, the skill stages the package at a predictable path and installs it with administrator privileges, which may allow code execution with root privileges after user approval.
Description
Missing integrity verification in the Progress Software Fiddler Download and Setup Skill on Linux, macOS, and Windows which allows an attacker to compromise or influence a release component and execute attacker-controlled code when a user runs the skill. On macOS, the skill stages the package at a predictable path and installs it with administrator privileges, which may allow code execution with root privileges after user approval. A local process may also replace the staged macOS package while the skill waits for approval.
Metrics
Weakness Enumeration
Affected Software
Source: CNA advisory (CVE.org). NVD analysis pending.
| Vendor | Product | Versions |
|---|---|---|
| Progress Software | Fiddler Download & Setup Skill | < 8.3.0 |
References
Timeline
- Published
- Last Modified
- Status
- Awaiting Analysis
Frequently Asked Questions
What is CVE-2026-104657?
How severe is CVE-2026-104657?
How do I fix CVE-2026-104657?
How Strix Helps
- How Strix found a critical auth bypass in etcdStrix autonomously discovered a critical authentication bypass in etcd, later designated CVE-2026-33413.
- Autonomous PentestingAI agents that find and validate exploitable vulnerabilities like this one across your applications.
- PR ReviewsPentest every pull request so vulnerable code is caught before it ships to production.
- AI Penetration TestingHow AI-driven penetration testing continuously covers your attack surface.
Related CVEs from 2026
- CVE-2026-104647The weMail WordPress plugin through 2.1.6 does not correctl…3.8
- CVE-2026-104648The weMail WordPress plugin through 2.1.6 does not restrict…4.9
- CVE-2026-104651The Yaad Sarig Payment Gateway For WC WordPress plugin befor…4.3
- CVE-2026-104652The Envira Gallery WordPress plugin before 1.16.1 does not …6.8
- CVE-2026-104653The Envira Gallery WordPress plugin before 1.16.1 does not …6.8
- CVE-2026-104656Improper neutralization of input in the sessions grid in Pro…7.3
- CVE-2026-104658The Linux live-update apply helper (hmailserver-update) of P…7.8
- CVE-2026-104659Missing Host header validation and missing throttling of fai…7.5
- CVE-2026-104660Missing authorization on COM objects in Progressive Robot hM…7.8
- CVE-2026-104661GitLab has remediated an issue in GitLab EE affecting all ve…4.3
- CVE-2026-104667The Animated Number Counters WordPress plugin before 3.1 doe…6.8
- CVE-2026-104670Unauthenticated Cross Site Scripting (XSS) in LearnPress <= …7.1
Are you affected by CVE-2026-104657?
Run a free Strix scan to check your systems for this vulnerability.
Scan your code nowSource: NVD / NIST
