CVE-2026-107147
Last modified
CVE-2026-107147 is a medium-severity vulnerability rated 6.3/10 on the CVSS scale. The twofactor_gauthenticator plugin for Roundcube is vulnerable to 2fa authentication bypass by spoofed client address headers. Due to the lack of validation of the Client-IP and X-Forwarded-For headers, an attacker who obtains user's password can spoof a whitelisted IP address, resulting in the second factor being bypassed. This issue was fixed in commit 4640889.. EPSS estimates a 0.48% chance of exploitation in the next 30 days.
Description
The twofactor_gauthenticator plugin for Roundcube is vulnerable to 2fa authentication bypass by spoofed client address headers. Due to the lack of validation of the Client-IP and X-Forwarded-For headers, an attacker who obtains user's password can spoof a whitelisted IP address, resulting in the second factor being bypassed. This issue was fixed in commit 4640889.
Metrics
Weakness Enumeration
Affected Software
Source: CNA advisory (CVE.org). NVD analysis pending.
| Vendor | Product | Versions |
|---|---|---|
| alexandregz | twofactor_gauthenticator | < 4640889 |
References
Timeline
- Published
- Last Modified
- Status
- Awaiting Analysis
Frequently Asked Questions
What is CVE-2026-107147?
How severe is CVE-2026-107147?
How do I fix CVE-2026-107147?
How Strix Helps
- Same Subject, Wrong User: A Cross-Issuer Account Takeover in n8nStrix found an identity-binding bug in n8n's token-exchange flow enabling account takeover.
- Autonomous PentestingAI agents that find and validate exploitable vulnerabilities like this one across your applications.
- PR ReviewsPentest every pull request so vulnerable code is caught before it ships to production.
- AI Penetration TestingHow AI-driven penetration testing continuously covers your attack surface.
Related CVEs from 2026
- CVE-2026-107126The WP Booking System WordPress plugin before 2.1.0.1 does …8.8
- CVE-2026-107127The Uncanny Toolkit for LearnDash WordPress plugin before 3.…7.5
- CVE-2026-107128The Uncanny Toolkit for LearnDash WordPress plugin before 3.…5
- CVE-2026-10714A security issue exists within FactoryTalk® Services Platfor…8.8
- CVE-2026-107145The twofactor_gauthenticator plugin for Roundcube is vulnera…6.3
- CVE-2026-107146The twofactor_gauthenticator plugin for Roundcube is vulnera…6.3
- CVE-2026-10715Camaleon CMS 2.9.2 contains an improper authorization vulner…5.1
- CVE-2026-107151Missing authentication has been found in remote-execution ta…5.9
- CVE-2026-107153Multiple smartphones provided by Rakuten Mobile, Inc. utiliz…7
- CVE-2026-107157Specially crafted CBOR input passed to QCborValue::fromCbor(…2
- CVE-2026-107158The LTL Freight Quotes WordPress plugin before 4.2.19 does …5.3
- CVE-2026-107159MiniUPnPd through 2.3.11 built with --strict contains a divi…6.5
Are you affected by CVE-2026-107147?
Run a free Strix scan to check your systems for this vulnerability.
Scan your code nowSource: NVD / NIST
