CVE-2026-107318
Last modified
CVE-2026-107318 is a high-severity vulnerability rated 7.4/10 on the CVSS scale. @fastify/reply-from is a Fastify plugin that forwards requests to an upstream HTTP or HTTPS server. In versions prior to 12.7.0, all of the built-in HTTPS transports override the secure default and set rejectUnauthorized to false, so the proxy does not verify the TLS certificate of the upstream even when the application points it at an https upstream in the default configuration.
Description
@fastify/reply-from is a Fastify plugin that forwards requests to an upstream HTTP or HTTPS server. In versions prior to 12.7.0, all of the built-in HTTPS transports override the secure default and set rejectUnauthorized to false, so the proxy does not verify the TLS certificate of the upstream even when the application points it at an https upstream in the default configuration. An on-path network attacker can therefore impersonate the configured HTTPS upstream, read the credentials and request bodies the proxy forwards, and return forged responses that the application trusts. The issue is fixed in @fastify/reply-from 12.7.0, and users should upgrade to 12.7.0 or later. As a workaround, pass an explicit rejectUnauthorized true on the transport, supply an already configured undici instance, or use the undici global agent.
Metrics
Weakness Enumeration
Affected Software
Source: CNA advisory (CVE.org). NVD analysis pending.
| Vendor | Product | Versions |
|---|---|---|
| @fastify/reply-from | @fastify/reply-from | < 12.7.0 |
References
Timeline
- Published
- Last Modified
- Status
- Deferred
Frequently Asked Questions
What is CVE-2026-107318?
How severe is CVE-2026-107318?
How do I fix CVE-2026-107318?
How Strix Helps
- How Strix found a critical auth bypass in etcdStrix autonomously discovered a critical authentication bypass in etcd, later designated CVE-2026-33413.
- Autonomous PentestingAI agents that find and validate exploitable vulnerabilities like this one across your applications.
- PR ReviewsPentest every pull request so vulnerable code is caught before it ships to production.
- AI Penetration TestingHow AI-driven penetration testing continuously covers your attack surface.
Related CVEs from 2026
- CVE-2026-107311Improper Check for Unusual or Exceptional Conditions vulnera…3.7
- CVE-2026-107312Allocation of Resources Without Limits or Throttling vulnera…4.3
- CVE-2026-107313pgjdbc, the PostgreSQL JDBC Driver, versions 42.7.4 and 42.7…4.2
- CVE-2026-107314pgjdbc, the PostgreSQL JDBC Driver, versions 42.7.11 through…5.9
- CVE-2026-107315pgjdbc, the PostgreSQL JDBC Driver, versions 42.7.4 through …5.3
- CVE-2026-107316Rejected reason: This CVE ID has been rejected or withdrawn …
- CVE-2026-107319The GamiPress WordPress plugin before 8.0.6 does not perfor…4.3
- CVE-2026-10732All versions of the package decompress are vulnerable to Arb…6.4
- CVE-2026-107320The GamiPress WordPress plugin before 8.0.6 does not proper…5.3
- CVE-2026-107321The W3 Total Cache WordPress plugin before 2.10.6 does not c…5.4
- CVE-2026-107322An incomplete list of disallowed inputs in Amazon Agent Plug…7.8
- CVE-2026-107323The Gallery PhotoBlocks WordPress plugin before 1.3.6 does n…6.8
Are you affected by CVE-2026-107318?
Run a free Strix scan to check your systems for this vulnerability.
Scan your code nowSource: NVD / NIST
