CVE-2026-109383
Last modified
CVE-2026-109383 is a critical-severity vulnerability rated 9.1/10 on the CVSS scale. undici is an HTTP client library for Node.js. In versions 4.0.0 through 6.29.0, 7.0.0 through 7.30.0, and 8.0.0 through 8.12.1, its Agent dispatcher passes its constructor options through a JSON-based deep clone before forwarding them to each per-origin pool, and because JSON cannot represent functions, a caller-supplied tls option containing a checkServerIdentity callback is silently dropped before it reaches the TLS layer. EPSS estimates a 0.18% chance of exploitation in the next 30 days.
Description
undici is an HTTP client library for Node.js. In versions 4.0.0 through 6.29.0, 7.0.0 through 7.30.0, and 8.0.0 through 8.12.1, its Agent dispatcher passes its constructor options through a JSON-based deep clone before forwarding them to each per-origin pool, and because JSON cannot represent functions, a caller-supplied tls option containing a checkServerIdentity callback is silently dropped before it reaches the TLS layer. As a result, a TLS peer whose certificate a custom checkServerIdentity was written to reject, but which passes Node's default hostname and chain checks, is silently accepted. Because Agent is the default dispatcher behind request, fetch, and setGlobalDispatcher, this affects the path most applications use, and EnvHttpProxyAgent is affected on its direct and no-proxy routes as well, while only applications that pass a function-valued tls option such as a custom checkServerIdentity for certificate or public-key pinning are at risk. The issue is fixed in undici 6.29.1, 7.30.1, and 8.12.2, which preserve the tls option outside the JSON clone so custom verification callbacks are forwarded unchanged, and users should upgrade to one of those versions or later. As a workaround, pass the TLS options through connect instead of tls, or for proxied destinations use requestTls and proxyTls.
Metrics
Weakness Enumeration
Affected Software
| Vendor | Product | Versions |
|---|---|---|
| Nodejs | Undici | >= 4.0.0, < 6.29.1 |
| Nodejs | Undici | >= 7.0.0, < 7.30.1 |
| Nodejs | Undici | >= 8.0.0, < 8.12.2 |
References
- https://cna.openjsf.org/security-advisories.htmlVendor Advisory
- https://github.com/nodejs/undici/security/advisories/GHSA-2m5v-pch6-74hxMitigation, Vendor Advisory
Timeline
- Published
- Last Modified
- Status
- Analyzed
Frequently Asked Questions
What is CVE-2026-109383?
How severe is CVE-2026-109383?
How do I fix CVE-2026-109383?
How Strix Helps
- How Strix found a critical auth bypass in etcdStrix autonomously discovered a critical authentication bypass in etcd, later designated CVE-2026-33413.
- Autonomous PentestingAI agents that find and validate exploitable vulnerabilities like this one across your applications.
- PR ReviewsPentest every pull request so vulnerable code is caught before it ships to production.
- AI Penetration TestingHow AI-driven penetration testing continuously covers your attack surface.
Related CVEs from 2026
- CVE-2026-109378SPIP before 4.4.18 contains a server-side request forgery vu…4.3
- CVE-2026-109379Cockpit CMS 2.14.1 contains an observable timing discrepancy…5.3
- CVE-2026-10938Inappropriate implementation in Input in Google Chrome prior…6.5
- CVE-2026-109380modern-tar 0.3.5 through 0.8.5 contains a memory exhaustion …7.5
- CVE-2026-109381The Mage Eventpress plugin for WordPress is vulnerable to pr…7.2
- CVE-2026-109382The WSP MCP AI Agents Connector plugin for WordPress is vuln…6.5
- CVE-2026-109384The The Innovative Form Builder – IvyForms plugin for WordPr…8.8
- CVE-2026-109385The UiChemy – Convert Figma, Prompts and AI Builds to Elemen…6.4
- CVE-2026-109386The Hustle – Email Marketing, Lead Generation, Optins, Popup…4.3
- CVE-2026-109388The HivePress – Business Directory, Listings & Classified Ad…6.4
- CVE-2026-10939Use after free in WebRTC in Google Chrome prior to 149.0.782…8.8
- CVE-2026-109390AnyDesk before 8.0.3 allows unauthenticated remote attackers…9.8
Are you affected by CVE-2026-109383?
Run a free Strix scan to check your systems for this vulnerability.
Scan your code nowSource: NVD / NIST
