CVE-2026-110180
Last modified
CVE-2026-110180 is a medium-severity vulnerability rated 4.8/10 on the CVSS scale. fast-uri is a dependency-free RFC 3986 URI parser and serializer for Node.js. In versions from 2.4.2 through 2.4.7, from 3.1.3 through 3.1.8, and from 4.0.1 through 4.2.2, for HTTP-family schemes the canonicalizeHost() function passes the parsed host to the WHATWG URL parser and adopts its hostname without checking that the parser consumed the entire input as a host, so the authority can be silently rewritten: data before an at-sign is dropped and tab, carriage-return, and line-feed characters are stripped, with no error reported. EPSS estimates a 0.21% chance of exploitation in the next 30 days.
Description
fast-uri is a dependency-free RFC 3986 URI parser and serializer for Node.js. In versions from 2.4.2 through 2.4.7, from 3.1.3 through 3.1.8, and from 4.0.1 through 4.2.2, for HTTP-family schemes the canonicalizeHost() function passes the parsed host to the WHATWG URL parser and adopts its hostname without checking that the parser consumed the entire input as a host, so the authority can be silently rewritten: data before an at-sign is dropped and tab, carriage-return, and line-feed characters are stripped, with no error reported. An application that enforces host-based policy such as denylists, loopback filtering, redirect validation, or outbound proxy routing on one representation can then see the canonical host diverge from what it checked, allowing traffic to be steered to an unintended destination. The issue is fixed in fast-uri 2.4.8, 3.1.9, and 4.2.3, and users should upgrade to one of these versions or later. As a workaround, reject an authority that contains more than one at-sign or any tab, carriage-return, or line-feed before calling fast-uri, or treat any non-empty parse error as fatal and compare hosts only from the same parse result.
Metrics
Weakness Enumeration
Affected Software
Source: CNA advisory (CVE.org). NVD analysis pending.
| Vendor | Product | Versions |
|---|---|---|
| fast-uri | fast-uri | >= 2.4.2, < 2.4.8; >= 3.1.3, < 3.1.9; >= 4.0.1, < 4.2.3 |
References
Timeline
- Published
- Last Modified
- Status
- Awaiting Analysis
Frequently Asked Questions
What is CVE-2026-110180?
How severe is CVE-2026-110180?
How do I fix CVE-2026-110180?
How Strix Helps
- How Strix found a critical auth bypass in etcdStrix autonomously discovered a critical authentication bypass in etcd, later designated CVE-2026-33413.
- Autonomous PentestingAI agents that find and validate exploitable vulnerabilities like this one across your applications.
- PR ReviewsPentest every pull request so vulnerable code is caught before it ships to production.
- AI Penetration TestingHow AI-driven penetration testing continuously covers your attack surface.
Related CVEs from 2026
- CVE-2026-11017Inappropriate implementation in Link Preview in Google Chrom…6.5
- CVE-2026-110170Use after free in Bindings in Google Chrome prior to 155.0.8…4.3
- CVE-2026-110171Use after free in Media in Google Chrome prior to 155.0.8059…8.8
- CVE-2026-110172Use after free in Media in Google Chrome prior to 155.0.8059…8.8
- CVE-2026-110179The affiliate-toolkit WordPress plugin before 3.8.9 does no…6.8
- CVE-2026-11018Insufficient policy enforcement in Actor in Google Chrome pr…6.5
- CVE-2026-110181PostgreSQL Anonymizer contains a vulnerability related to an…6.5
- CVE-2026-110182PostgreSQL Anonymizer contains a vulnerability related to th…4.3
- CVE-2026-110183PostgreSQL Anonymizer contains a vulnerability related to st…4.3
- CVE-2026-110184The Newsmatic theme for WordPress is vulnerable to blind SQL…7.5
- CVE-2026-110185The Bit Flows: AI Agent Automation & Integrations for Forms,…5.9
- CVE-2026-110186IBM Langflow OSS 1.0.0 through 1.12.8 could allow a remote a…9.8
Are you affected by CVE-2026-110180?
Run a free Strix scan to check your systems for this vulnerability.
Scan your code nowSource: NVD / NIST
