CVE-2026-110725
Last modified
CVE-2026-110725 is a low-severity vulnerability rated 3.7/10 on the CVSS scale. fast-uri is a dependency-free RFC 3986 URI parser and serializer for Node.js. In versions before 2.4.8, from 3.0.0 through 3.1.8, and from 4.0.0 through 4.2.2, when serialize(), normalize(), or resolve() are called with the non-default option reference set to suffix on a reference that has no authority, the emitted relative reference can contain a bare colon in its first path segment without escaping it, even though RFC 3986 forbids that because it makes the string reparse as an absolute URI with a scheme. EPSS estimates a 0.25% chance of exploitation in the next 30 days.
Description
fast-uri is a dependency-free RFC 3986 URI parser and serializer for Node.js. In versions before 2.4.8, from 3.0.0 through 3.1.8, and from 4.0.0 through 4.2.2, when serialize(), normalize(), or resolve() are called with the non-default option reference set to suffix on a reference that has no authority, the emitted relative reference can contain a bare colon in its first path segment without escaping it, even though RFC 3986 forbids that because it makes the string reparse as an absolute URI with a scheme. An application that serializes or normalizes a relative reference with the suffix option and then treats the result as a URI can turn inert input into a live javascript, data, or vbscript URL, a cross-site scripting vector, and the equal() comparison can conflate a scheme-bearing reference with a relative one. Exposure is limited to applications using the non-default suffix reference option. The issue is fixed in fast-uri 2.4.8, 3.1.9, and 4.2.3, and users should upgrade to one of these versions or later. As a workaround, avoid the suffix reference option on untrusted input, or percent-encode a colon in the first path segment of the result before treating it as a URI.
Metrics
Weakness Enumeration
Affected Software
Source: CNA advisory (CVE.org). NVD analysis pending.
| Vendor | Product | Versions |
|---|---|---|
| fast-uri | fast-uri | < 2.4.8; >= 3.0.0, < 3.1.9; >= 4.0.0, < 4.2.3 |
References
Timeline
- Published
- Last Modified
- Status
- Awaiting Analysis
Frequently Asked Questions
What is CVE-2026-110725?
How severe is CVE-2026-110725?
How do I fix CVE-2026-110725?
How Strix Helps
- How Strix found a critical auth bypass in etcdStrix autonomously discovered a critical authentication bypass in etcd, later designated CVE-2026-33413.
- Autonomous PentestingAI agents that find and validate exploitable vulnerabilities like this one across your applications.
- PR ReviewsPentest every pull request so vulnerable code is caught before it ships to production.
- AI Penetration TestingHow AI-driven penetration testing continuously covers your attack surface.
Related CVEs from 2026
- CVE-2026-110719Portkey AI Gateway 1.14.0 through 1.15.2 contains a server-s…7.2
- CVE-2026-11072Use after free in WebView in Google Chrome on Android prior …7.8
- CVE-2026-110720Consul-k8s versions 0.42.0 and later are vulnerable to a cro…9.9
- CVE-2026-110721The NotificationX plugin for WordPress is vulnerable to Miss…5.3
- CVE-2026-110723In `api-gateway` versions till `1.7.3`, The default rate-lim…7.5
- CVE-2026-110724In `api-gateway` versions till `1.7.3`, The default rate-lim…7.5
- CVE-2026-110726In `api-gateway` versions till `1.7.3`, The default rate-lim…6.5
- CVE-2026-11073Use after free in WebGL in Google Chrome prior to 149.0.7827…6.5
- CVE-2026-110732The AI Engine – The Chatbot, AI Framework & MCP for WordPres…7.5
- CVE-2026-110733Vulnerability in the SQL storage module of Apache SIS. When …5.4
- CVE-2026-110734Godot Engine through 4.7.2 has a heap out-of-bounds write in…2.5
- CVE-2026-110735Godot Engine through 4.7.2 has a heap out-of-bounds write in…2.5
Are you affected by CVE-2026-110725?
Run a free Strix scan to check your systems for this vulnerability.
Scan your code nowSource: NVD / NIST
