CVE-2026-111959
Last modified
CVE-2026-111959 is a critical-severity vulnerability rated 9.1/10 on the CVSS scale. Out-of-bounds read vulnerability in Apache Arrow Rust (`arrow` crate), from version 33.0.0 through to versions 57.3.1, 58.4.0, 59.3.1 and 60.0.0. Improper validation of RunEndEncoded arrays in the ArrayData interface can allow reading data beyond the bounds of the child values array. Users are recommended to upgrade to versions 60.1.0, 59.3.2, 58.4.1, 57.3.2 which fixes the issue.. EPSS estimates a 0.23% chance of exploitation in the next 30 days.
Description
Out-of-bounds read vulnerability in Apache Arrow Rust (`arrow` crate), from version 33.0.0 through to versions 57.3.1, 58.4.0, 59.3.1 and 60.0.0. Improper validation of RunEndEncoded arrays in the ArrayData interface can allow reading data beyond the bounds of the child values array. Users are recommended to upgrade to versions 60.1.0, 59.3.2, 58.4.1, 57.3.2 which fixes the issue.
Metrics
Weakness Enumeration
Affected Software
Source: CNA advisory (CVE.org). NVD analysis pending.
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Arrow Rust | >= 60.0.0, < 60.1.0; >= 59.0.0, <= 59.3.1; >= 58.0.0, <= 58.4.0; >= 33.0.0, <= 57.3.1 |
References
Timeline
- Published
- Last Modified
- Status
- Awaiting Analysis
Frequently Asked Questions
What is CVE-2026-111959?
How severe is CVE-2026-111959?
How do I fix CVE-2026-111959?
How Strix Helps
- How Strix found a critical auth bypass in etcdStrix autonomously discovered a critical authentication bypass in etcd, later designated CVE-2026-33413.
- Autonomous PentestingAI agents that find and validate exploitable vulnerabilities like this one across your applications.
- PR ReviewsPentest every pull request so vulnerable code is caught before it ships to production.
- AI Penetration TestingHow AI-driven penetration testing continuously covers your attack surface.
Related CVEs from 2026
- CVE-2026-111949The miniOrange 2FA WordPress plugin before 6.3.1 does not p…7.5
- CVE-2026-11195Inappropriate implementation in MHTML in Google Chrome prior…6.5
- CVE-2026-111955The WholesaleX WordPress plugin before 3.0.9 does not check…6.5
- CVE-2026-111956The WholesaleX WordPress plugin before 3.0.9 does not prote…5.9
- CVE-2026-111957The SUMIT Payment Gateway for WooCommerce WordPress plugin b…5.3
- CVE-2026-111958The Royal MCP WordPress plugin before 1.5.7 does not limit …7.5
- CVE-2026-11196Type Confusion in XML in Google Chrome prior to 149.0.7827.5…6.5
- CVE-2026-111960The Royal MCP WordPress plugin before 1.5.10 does not perfo…4.3
- CVE-2026-111961The Royal MCP WordPress plugin before 1.5.10 does not perfo…3.8
- CVE-2026-111962The WP Remote Users Sync WordPress plugin before 2.2.0 does …3.7
- CVE-2026-111965The Profile Builder WordPress plugin from 4.0.0 to 4.0.4 doe…4.3
- CVE-2026-111966The User Profile Builder WordPress plugin before 4.0.5 does…6.8
Are you affected by CVE-2026-111959?
Run a free Strix scan to check your systems for this vulnerability.
Scan your code nowSource: NVD / NIST
