CVE-2026-114427
Last modified
CVE-2026-114427 is a medium-severity vulnerability rated 6.8/10 on the CVSS scale. The GutenKit WordPress plugin before 2.5.5 does not properly sanitize custom CSS saved against a post before printing it inside an inline style block on the published page, allowing users with the Author role and above to break out of the style element and store JavaScript that executes in the browser of any visitor who views the post. Exploitation affects sites running WordPress below 7.0.. EPSS estimates a 0.16% chance of exploitation in the next 30 days.
Description
The GutenKit WordPress plugin before 2.5.5 does not properly sanitize custom CSS saved against a post before printing it inside an inline style block on the published page, allowing users with the Author role and above to break out of the style element and store JavaScript that executes in the browser of any visitor who views the post. Exploitation affects sites running WordPress below 7.0.
Metrics
Weakness Enumeration
Affected Software
Source: CNA advisory (CVE.org). NVD analysis pending.
| Vendor | Product | Versions |
|---|---|---|
| Unknown | GutenKit | >= 2.5.0, < 2.5.5 |
References
Timeline
- Published
- Last Modified
- Status
- Deferred
Frequently Asked Questions
What is CVE-2026-114427?
How severe is CVE-2026-114427?
How do I fix CVE-2026-114427?
How Strix Helps
- How Strix found a critical auth bypass in etcdStrix autonomously discovered a critical authentication bypass in etcd, later designated CVE-2026-33413.
- Autonomous PentestingAI agents that find and validate exploitable vulnerabilities like this one across your applications.
- PR ReviewsPentest every pull request so vulnerable code is caught before it ships to production.
- AI Penetration TestingHow AI-driven penetration testing continuously covers your attack surface.
Related CVEs from 2026
- CVE-2026-114420SEPPmail Secure Email Gateway before 15.1.1 does not neutral…6.9
- CVE-2026-114421SEPPmail Secure Email Gateway before 15.1.1 permits password…8.3
- CVE-2026-114422The Enable Media Replace WordPress plugin before 4.2.3 does …7.5
- CVE-2026-114424SEPPmail Secure Email Gateway before 15.1.1 can evaluate att…9.2
- CVE-2026-114425SEPPmail Secure Email Gateway before 15.1.1 trusts a file pa…9.2
- CVE-2026-114426SEPPmail Secure Email Gateway before 15.1.1 processes and wr…8.7
- CVE-2026-114429The WPVR WordPress plugin before 9.0.3 does not properly sa…6.8
- CVE-2026-11443Allegra downloadAttachment Cross-Site Scripting Authenticati…4.6
- CVE-2026-114431The Enable Media Replace WordPress plugin before 4.2.3 does …6.4
- CVE-2026-114437In the Golang Chi web framework, the ClientIPFromXFF middlew…4.8
- CVE-2026-114438A flaw was found in the Update User Locale required action o…4.2
- CVE-2026-114439A vulnerability was determined in oretnom23 php-travel-agenc…7.3
Are you affected by CVE-2026-114427?
Run a free Strix scan to check your systems for this vulnerability.
Scan your code nowSource: NVD / NIST
