CVE-2026-115657
Last modified
CVE-2026-115657 is a medium-severity vulnerability rated 4.8/10 on the CVSS scale. When used as an executor in either KNIME Server or KNIME Business Hub, KNIME Analytics Platform LTS versions before 5.8.4 log configured credentials of proxies during startup. An attacker with access to log files can steal the credentials and use the proxy as the user who configured the proxy settings. EPSS estimates a 0.10% chance of exploitation in the next 30 days.
Description
When used as an executor in either KNIME Server or KNIME Business Hub, KNIME Analytics Platform LTS versions before 5.8.4 log configured credentials of proxies during startup. An attacker with access to log files can steal the credentials and use the proxy as the user who configured the proxy settings. The issue has been fixed in LTS versions 5.8.4 and 5.12.0 and later.
Metrics
Weakness Enumeration
Affected Software
Source: CNA advisory (CVE.org). NVD analysis pending.
| Vendor | Product | Versions |
|---|---|---|
| KNIME | KNIME Analytics Platform | All versions |
References
Timeline
- Published
- Last Modified
- Status
- Awaiting Analysis
Frequently Asked Questions
What is CVE-2026-115657?
How severe is CVE-2026-115657?
How do I fix CVE-2026-115657?
How Strix Helps
- How Strix found a critical auth bypass in etcdStrix autonomously discovered a critical authentication bypass in etcd, later designated CVE-2026-33413.
- Autonomous PentestingAI agents that find and validate exploitable vulnerabilities like this one across your applications.
- PR ReviewsPentest every pull request so vulnerable code is caught before it ships to production.
- AI Penetration TestingHow AI-driven penetration testing continuously covers your attack surface.
Related CVEs from 2026
- CVE-2026-115627Incorrect Authorization vulnerability in ash-project ash_pos…6
- CVE-2026-11563The Word Count and Social Shares WordPress plugin through 1.…9.6
- CVE-2026-115635Incorrect Authorization vulnerability in ash-project ash_pos…6
- CVE-2026-115638OpenStack Ironic through 39.0.1 allows a denial of service v…4.3
- CVE-2026-11564libcurl keeps previously used connections in a connection po…9.1
- CVE-2026-11565The Advanced File Manager WordPress plugin before 5.4.13 do…8.5
- CVE-2026-11567The SureForms WordPress plugin before 2.11.1 does not prope…5.9
- CVE-2026-115678Arm Keil MDK-Middleware 8.0.0-8.3.0 may allow pre-authentica…5.3
- CVE-2026-115679Arm Keil MDK-Middleware 8.3.0 may allow out-of-bounds reads …6.5
- CVE-2026-11568The Product Configurator for WooCommerce WordPress plugin be…7.5
- CVE-2026-115680Arm Keil MDK-Middleware 8.0.0-8.3.0 may allow DHCPv6 Option-…6.5
- CVE-2026-11569A flaw was found in Quay. The filedrop endpoint accepts any …5.4
Are you affected by CVE-2026-115657?
Run a free Strix scan to check your systems for this vulnerability.
Scan your code nowSource: NVD / NIST
