CVE-2026-118237
Last modified
CVE-2026-118237 is a medium-severity vulnerability rated 5.3/10 on the CVSS scale. An out-of-bounds read vulnerability was identified in GitHub Enterprise Server in the Git service (babeld). When proving possession of a host key, babeld's SSH implementation sized the session identifier by the current digest length rather than its own. EPSS estimates a 0.27% chance of exploitation in the next 30 days.
Description
An out-of-bounds read vulnerability was identified in GitHub Enterprise Server in the Git service (babeld). When proving possession of a host key, babeld's SSH implementation sized the session identifier by the current digest length rather than its own. An attacker with an account and SSH access could re-key to an algorithm with a longer hash, causing adjacent process memory to be signed and returned to the client, where a limited amount of it may be recoverable. This vulnerability affected all releases prior to 3.23 and was fixed in versions 3.22.3, 3.21.8, 3.20.10, and 3.19.14. This vulnerability was reported via the GitHub Bug Bounty program.
Metrics
Weakness Enumeration
Affected Software
Source: CNA advisory (CVE.org). NVD analysis pending.
| Vendor | Product | Versions |
|---|---|---|
| GitHub | Enterprise Server | >= 3.19.0, < 3.19.*; >= 3.20.0, < 3.20.*; >= 3.21.0, < 3.21.*; >= 3.22.0, < 3.22.* |
References
Timeline
- Published
- Last Modified
- Status
- Received
Frequently Asked Questions
What is CVE-2026-118237?
How severe is CVE-2026-118237?
How do I fix CVE-2026-118237?
How Strix Helps
- How Strix found a critical auth bypass in etcdStrix autonomously discovered a critical authentication bypass in etcd, later designated CVE-2026-33413.
- Autonomous PentestingAI agents that find and validate exploitable vulnerabilities like this one across your applications.
- PR ReviewsPentest every pull request so vulnerable code is caught before it ships to production.
- AI Penetration TestingHow AI-driven penetration testing continuously covers your attack surface.
Related CVEs from 2026
- CVE-2026-11820A flaw was found in the community.general Ansible collection…6.5
- CVE-2026-118205The Essential Addons for Elementor – Popular Elementor Templ…7.4
- CVE-2026-11821The Eventin – Event Calendar, Event Registration, Tickets & …5.4
- CVE-2026-11822SQLite before 3.53.2 contains an out-of-bounds read vulnerab…5.5
- CVE-2026-11823The BookingPress Appointment Booking Pro plugin for WordPres…7.5
- CVE-2026-118235The SimpleForm – Form Maker to Chat Apps with Quiz, Poll and…9.8
- CVE-2026-118238The Tenda W18E web management server is vulnerable to OS com…7.2
- CVE-2026-118239The AutomatorWP WordPress plugin before 6.0.7 does not chec…5.6
- CVE-2026-11824SQLite before 3.53.2 contains a heap-based buffer overflow v…7.8
- CVE-2026-118242Highcharts JS is a JavaScript charting library based on SVG.…8.5
- CVE-2026-118243Highcharts JS is a JavaScript charting library based on SVG.…5.3
- CVE-2026-118244Highcharts JS is a JavaScript charting library based on SVG.…7.2
Are you affected by CVE-2026-118237?
Run a free Strix scan to check your systems for this vulnerability.
Scan your code nowSource: NVD / NIST
