CVE-2026-118682
Last modified
CVE-2026-118682 is a high-severity vulnerability rated 7.5/10 on the CVSS scale. KaringX ClashMi through 1.0.32.1801 disables TLS certificate validation by default in the HttpUtils helper, allowing attackers to intercept HTTPS traffic by presenting any certificate. Attackers operating the user's proxy node can serve a forged update manifest omitting sha256 to deliver a malicious installer, achieving code execution when the update runs.. EPSS estimates a 0.27% chance of exploitation in the next 30 days.
Description
KaringX ClashMi through 1.0.32.1801 disables TLS certificate validation by default in the HttpUtils helper, allowing attackers to intercept HTTPS traffic by presenting any certificate. Attackers operating the user's proxy node can serve a forged update manifest omitting sha256 to deliver a malicious installer, achieving code execution when the update runs.
Metrics
Weakness Enumeration
Affected Software
Source: CNA advisory (CVE.org). NVD analysis pending.
| Vendor | Product | Versions |
|---|---|---|
| KaringX | clashmi | <= 1.0.32.1801 |
References
Timeline
- Published
- Last Modified
- Status
- Deferred
Frequently Asked Questions
What is CVE-2026-118682?
How severe is CVE-2026-118682?
How do I fix CVE-2026-118682?
How Strix Helps
- How Strix found a critical auth bypass in etcdStrix autonomously discovered a critical authentication bypass in etcd, later designated CVE-2026-33413.
- Autonomous PentestingAI agents that find and validate exploitable vulnerabilities like this one across your applications.
- PR ReviewsPentest every pull request so vulnerable code is caught before it ships to production.
- AI Penetration TestingHow AI-driven penetration testing continuously covers your attack surface.
Related CVEs from 2026
- CVE-2026-118677n8n before 2.41.4 and 2.42.x before 2.42.1 contains a missin…5.9
- CVE-2026-118678n8n before 2.41.4 and 2.42.x before 2.42.1 contains a protot…7.1
- CVE-2026-118679n8n before 1.123.83, 2.41.4, and 2.42.1 contains a server-si…7.5
- CVE-2026-11868The WP Travel WordPress plugin before 11.7.1 does not perfo…5.3
- CVE-2026-118680SiYuan 3.8.7 through 3.8.8 fails to normalize Windows GLOBAL…4.4
- CVE-2026-118681go-chi chi before 5.5.0 contains an authentication bypass in…3.7
- CVE-2026-118683MONAI from 1.2.0 before 1.6.1 contains a remote code executi…8.8
- CVE-2026-118684MONAI before 1.6.1 contains an insufficient integrity verifi…5.9
- CVE-2026-118685ToolJet from 3.20.2-lts before 3.20.242-lts contains an auth…6.5
- CVE-2026-118686EspoCRM before 9.3.11 and 10.x before 10.0.8 contains a deni…7.5
- CVE-2026-118687Coder before 2.29.21, 2.30.0 before 2.34.12, 2.35.0 before 2…6.5
- CVE-2026-118688wasmtime-wasi in Wasmtime before 36.0.18, 37.0.0 before 48.0…7.9
Are you affected by CVE-2026-118682?
Run a free Strix scan to check your systems for this vulnerability.
Scan your code nowSource: NVD / NIST
