CVE-2026-120627
Last modified
CVE-2026-120627 is a vulnerability of currently unknown severity. The Private Internet Access Extension for Firefox contains an unguarded onAuthRequired authentication handler, leading to leakage of PIA proxy credentials when a user visits any malicious website that issues a Basic auth challenge. This issue was fixed in version 3.2.5, but reintroduced in later versions..
Description
The Private Internet Access Extension for Firefox contains an unguarded onAuthRequired authentication handler, leading to leakage of PIA proxy credentials when a user visits any malicious website that issues a Basic auth challenge. This issue was fixed in version 3.2.5, but reintroduced in later versions.
Weakness Enumeration
Affected Software
Source: CNA advisory (CVE.org). NVD analysis pending.
| Vendor | Product | Versions |
|---|---|---|
| Private Internet Access | Firefox extension | >= 3.2.5, <= 4.0.5 |
References
Timeline
- Published
- Last Modified
- Status
- Awaiting Analysis
Frequently Asked Questions
What is CVE-2026-120627?
How severe is CVE-2026-120627?
How do I fix CVE-2026-120627?
How Strix Helps
- How Strix found a critical auth bypass in etcdStrix autonomously discovered a critical authentication bypass in etcd, later designated CVE-2026-33413.
- Autonomous PentestingAI agents that find and validate exploitable vulnerabilities like this one across your applications.
- PR ReviewsPentest every pull request so vulnerable code is caught before it ships to production.
- AI Penetration TestingHow AI-driven penetration testing continuously covers your attack surface.
Related CVEs from 2026
- CVE-2026-12058The connection confirmation pop-up of a specific feature in …5.3
- CVE-2026-12059The SSH service of CelloOS developed by Cellopoint has an Im…8.8
- CVE-2026-120596A remotely exploitable denial-of-service vulnerability exist…7.5
- CVE-2026-120597A vulnerability was identified in Welcart e-Commerce Plugin …4.3
- CVE-2026-1206The Elementor Website Builder plugin for WordPress is vulner…4.3
- CVE-2026-12060Heptabase developed by Hepta Platforms has a Exposed Dangero…6.5
- CVE-2026-120630CrewAI contains an SSRF vulnerability caused by its SSRF gua…
- CVE-2026-120631CGI::Cookie versions from 4.67 before 5.00 for Perl allow de…
- CVE-2026-120632CGI versions before 5.00 for Perl allow CPU exhaustion via a…
- CVE-2026-120633CGI versions before 5.00 for Perl trust the client X-Forward…
- CVE-2026-120634CGI::Carp versions before 5.00 for Perl leak warnings across…
- CVE-2026-120635CGI versions before 5.00 for Perl allow form fields to be sm…
Are you affected by CVE-2026-120627?
Run a free Strix scan to check your systems for this vulnerability.
Scan your code nowSource: NVD / NIST
