CVE-2026-14298
Last modified
CVE-2026-14298 is a medium-severity vulnerability rated 6.5/10 on the CVSS scale. Mattermost versions 11.9.x <= 11.9.0, 11.8.x <= 11.8.4, 11.7.x <= 11.7.7, 10.11.x <= 10.11.22 fail to limit decompressed content size and enforce the configured maximum file size in the Boards archive import handler, which allows an authenticated user to cause memory exhaustion or unbounded disk consumption via a crafted .boardarchive file uploaded to the import endpoint.. Mattermost Advisory ID: MMSA-2026-00713. EPSS estimates a 0.24% chance of exploitation in the next 30 days.
Description
Mattermost versions 11.9.x <= 11.9.0, 11.8.x <= 11.8.4, 11.7.x <= 11.7.7, 10.11.x <= 10.11.22 fail to limit decompressed content size and enforce the configured maximum file size in the Boards archive import handler, which allows an authenticated user to cause memory exhaustion or unbounded disk consumption via a crafted .boardarchive file uploaded to the import endpoint.. Mattermost Advisory ID: MMSA-2026-00713
Metrics
Weakness Enumeration
Affected Software
| Vendor | Product | Versions |
|---|---|---|
| Mattermost | Mattermost Server | >= 10.11.0, < 10.11.23 |
| Mattermost | Mattermost Server | >= 11.7.0, < 11.7.8 |
| Mattermost | Mattermost Server | >= 11.8.0, < 11.8.5 |
| Mattermost | Mattermost Server | >= 11.9.0, < 11.9.1 |
References
- https://mattermost.com/security-updatesVendor Advisory
Timeline
- Published
- Last Modified
- Status
- Modified
Frequently Asked Questions
What is CVE-2026-14298?
How severe is CVE-2026-14298?
How do I fix CVE-2026-14298?
How Strix Helps
- How Strix found a critical auth bypass in etcdStrix autonomously discovered a critical authentication bypass in etcd, later designated CVE-2026-33413.
- Autonomous PentestingAI agents that find and validate exploitable vulnerabilities like this one across your applications.
- PR ReviewsPentest every pull request so vulnerable code is caught before it ships to production.
- AI Penetration TestingHow AI-driven penetration testing continuously covers your attack surface.
Related CVEs from 2026
- CVE-2026-14290The Embed Google Photos album WordPress plugin through 2.2.1…6.8
- CVE-2026-14291The security-ninja-premium WordPress plugin before 5.290 doe…7.5
- CVE-2026-14292The Download Manager WordPress plugin before 3.3.66 does not…5.4
- CVE-2026-14293The Autopay WordPress plugin before 5.0.1 does not perform a…8.8
- CVE-2026-14296When using the Direct XIP update strategy, the main applicat…7.5
- CVE-2026-14297A buffer overflow in the Bluetooth Continuous Glucose M…8.7
- CVE-2026-1430The WP Lightbox 2 WordPress plugin before 3.0.7 does not san…4.8
- CVE-2026-14300The miniOrange Social Login and Register (Discord, Google, T…8.1
- CVE-2026-14304In Eclipse Accessibility Tools Framework (ACTF) versions up …5.5
- CVE-2026-14305The WP Delicious WordPress plugin before 1.10.2 does not pe…5.3
- CVE-2026-14306The Tutor LMS WordPress plugin before 3.9.14 does not proper…4.3
- CVE-2026-14307The geotargetingwp WordPress plugin before 3.5.6.2 does not …7.1
Are you affected by CVE-2026-14298?
Run a free Strix scan to check your systems for this vulnerability.
Scan your code nowSource: NVD / NIST
