CVE-2026-14644

HIGHCVSS 7.2/10EPSS 0.27%

Last modified

CVE-2026-14644 is a high-severity vulnerability rated 7.2/10 on the CVSS scale. Nexus Repository 3 contained a privilege escalation vulnerability in the REST privileges API. An authenticated user with permission to manage privileges could, under certain role configurations, escalate their own access to full administrator by exploiting a type-confusion flaw in the privilege update endpoint.. EPSS estimates a 0.27% chance of exploitation in the next 30 days.

Description

Nexus Repository 3 contained a privilege escalation vulnerability in the REST privileges API. An authenticated user with permission to manage privileges could, under certain role configurations, escalate their own access to full administrator by exploiting a type-confusion flaw in the privilege update endpoint.

Metrics

Weakness Enumeration

Affected Software

VendorProductVersions
SonatypeNexus Repository Manager>= 3.19.0, < 3.95.0

References

Timeline

Published
Last Modified
Status
Analyzed

Frequently Asked Questions

What is CVE-2026-14644?
Nexus Repository 3 contained a privilege escalation vulnerability in the REST privileges API. An authenticated user with permission to manage privileges could, under certain role configurations, escalate their own access to full administrator by exploiting a type-confusion flaw in the privilege update endpoint.
How severe is CVE-2026-14644?
CVE-2026-14644 has a CVSS score of 7.2/10 (HIGH severity). The EPSS model estimates a 0.27% probability of exploitation in the next 30 days.
How do I fix CVE-2026-14644?
Check the vendor references and advisories linked above for patched versions and mitigation guidance. You can also run a Strix scan to test if your systems are affected.

How Strix Helps

Related CVEs from 2026

Are you affected by CVE-2026-14644?

Run a free Strix scan to check your systems for this vulnerability.

Scan your code now

Source: NVD / NIST