CVE-2026-69077
Last modified
CVE-2026-69077 is a high-severity vulnerability rated 7.5/10 on the CVSS scale. Exposure of unauthorized cross-project job manipulation vulnerability in Apache Kylin. Impact most to the kylin services that are directly exposed to public network, which is not common. In-house kylin deployments are mostly not impacted. This issue affects Apache Kylin: from 4 through 5.0.4. Users are recommended to upgrade to version 5.0.5, which fixes the issue.. EPSS estimates a 0.20% chance of exploitation in the next 30 days.
Description
Exposure of unauthorized cross-project job manipulation vulnerability in Apache Kylin. Impact most to the kylin services that are directly exposed to public network, which is not common. In-house kylin deployments are mostly not impacted. This issue affects Apache Kylin: from 4 through 5.0.4. Users are recommended to upgrade to version 5.0.5, which fixes the issue.
Metrics
Weakness Enumeration
Affected Software
Source: CNA advisory (CVE.org). NVD analysis pending.
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Kylin | >= 4..0.0, <= 5.0.4 |
References
Timeline
- Published
- Last Modified
- Status
- Deferred
Frequently Asked Questions
What is CVE-2026-69077?
How severe is CVE-2026-69077?
How do I fix CVE-2026-69077?
How Strix Helps
- How Strix found a critical auth bypass in etcdStrix autonomously discovered a critical authentication bypass in etcd, later designated CVE-2026-33413.
- Autonomous PentestingAI agents that find and validate exploitable vulnerabilities like this one across your applications.
- PR ReviewsPentest every pull request so vulnerable code is caught before it ships to production.
- AI Penetration TestingHow AI-driven penetration testing continuously covers your attack surface.
Related CVEs from 2026
- CVE-2026-69050Out-of-bounds memory access in a device driver due to improp…
- CVE-2026-69066Memory corruption in GPU driver due to improper validation o…
- CVE-2026-69068Insufficient length validation in the GNSS firmware loader m…
- CVE-2026-6907An issue was discovered in 6.0 before 6.0.5 and 5.2 before 5…5.3
- CVE-2026-69075FlowIntel is affected by a stored cross-site scripting vulne…6.9
- CVE-2026-69076Exposure of Job Discard to an Unauthorized Actor vulnerabili…7.5
- CVE-2026-69078CTI-Transmute is affected by a server-side request forgery v…8.8
- CVE-2026-69079CTI-Transmute contains an uncontrolled resource-consumption …8.7
- CVE-2026-69080Exposure of SQL Black List to an Unauthorized Actor vulnerab…7.5
- CVE-2026-69082CTI-Transmute contained a cross-site request forgery vulnera…8.8
- CVE-2026-69083SiYuan versions before v3.7.3 contain SQL injection vulnerab…10
- CVE-2026-69084SiYuan versions <= v3.7.2 expose the /api/search/searchEmbed…10
Are you affected by CVE-2026-69077?
Run a free Strix scan to check your systems for this vulnerability.
Scan your code nowSource: NVD / NIST
