CVE-2026-77078
Last modified
CVE-2026-77078 is a high-severity vulnerability rated 7.5/10 on the CVSS scale. multer is a middleware for handling multipart/form-data in Node.js. A small multipart request containing two specially crafted text field names can cause an uncaught RangeError (Invalid array length) that terminates the Node.js process. EPSS estimates a 0.29% chance of exploitation in the next 30 days.
Description
multer is a middleware for handling multipart/form-data in Node.js. A small multipart request containing two specially crafted text field names can cause an uncaught RangeError (Invalid array length) that terminates the Node.js process. The first field uses a very large numeric array index to allocate a maximum-length sparse array, and a second field then pushes past that length, which throws inside the append-field dependency and is not caught by multer. All versions before 2.3.0 are affected, and the issue is a remotely triggerable denial of service. The issue is fixed in multer 2.3.0. Upgrade to multer 2.3.0 to remediate.
Metrics
Weakness Enumeration
Affected Software
| Vendor | Product | Versions |
|---|---|---|
| Expressjs | Multer | < 2.3.0 |
References
Timeline
- Published
- Last Modified
- Status
- Analyzed
Frequently Asked Questions
What is CVE-2026-77078?
How severe is CVE-2026-77078?
How do I fix CVE-2026-77078?
How Strix Helps
- How Strix found a critical auth bypass in etcdStrix autonomously discovered a critical authentication bypass in etcd, later designated CVE-2026-33413.
- Autonomous PentestingAI agents that find and validate exploitable vulnerabilities like this one across your applications.
- PR ReviewsPentest every pull request so vulnerable code is caught before it ships to production.
- AI Penetration TestingHow AI-driven penetration testing continuously covers your attack surface.
Related CVEs from 2026
- CVE-2026-77072n8n before 1.123.69, 2.33.4, and 2.34.1 contains a stored cr…7.6
- CVE-2026-77073n8n versions before 2.34.1 contain a credential validation b…4.3
- CVE-2026-77074n8n versions before 1.123.69 contain a server-side request f…6.5
- CVE-2026-77075n8n before 1.123.69, 2.x before 2.33.4, and 2.34.x before 2.…7.3
- CVE-2026-77076n8n versions before 1.123.69, 2.33.4, and 2.34.1 contain an …6.5
- CVE-2026-77077n8n versions before 1.123.69, 2.33.4, and 2.34.1 contain a J…7.6
- CVE-2026-77079n8n before 2.34.1 and 2.33.4 contains an authorization bypas…8.8
- CVE-2026-7708A vulnerability was determined in Open5GS up to 2.7.7. The a…4.3
- CVE-2026-77080n8n before 1.123.69, 2.x before 2.33.4, and 2.34.x before 2.…8.8
- CVE-2026-77081n8n before 1.123.69, 2.x before 2.33.4, and 2.x before 2.34.…7.1
- CVE-2026-77082n8n before 1.123.69, 2.x before 2.33.4, and 2.34.x before 2.…4.3
- CVE-2026-77083n8n is a workflow automation platform. In versions prior to …5.9
Are you affected by CVE-2026-77078?
Run a free Strix scan to check your systems for this vulnerability.
Scan your code nowSource: NVD / NIST
