CVE-2026-8145
Last modified
CVE-2026-8145 is a medium-severity vulnerability rated 5.4/10 on the CVSS scale. The WholesaleX – B2B & Wholesale Plugin for WooCommerce with Wholesale Prices plugin for WordPress is vulnerable to Limited Privilege Escalation in all versions up to, and including, 3.0.8 via the 'process_registration' due to missing validation on the 'wholesalex_registration_role' parameter. This makes it possible for unauthenticated attackers to register as any existing WholesaleX role.
Description
The WholesaleX – B2B & Wholesale Plugin for WooCommerce with Wholesale Prices plugin for WordPress is vulnerable to Limited Privilege Escalation in all versions up to, and including, 3.0.8 via the 'process_registration' due to missing validation on the 'wholesalex_registration_role' parameter. This makes it possible for unauthenticated attackers to register as any existing WholesaleX role. The vulnerability was partially patched in version 2.3.8.
Metrics
Weakness Enumeration
Affected Software
Source: CNA advisory (CVE.org). NVD analysis pending.
| Vendor | Product | Versions |
|---|---|---|
| wpxpo | WholesaleX – All-in-One B2B Solution with Wholesale Pricing | <= 3.0.8 |
References
Timeline
- Published
- Last Modified
- Status
- Deferred
Frequently Asked Questions
What is CVE-2026-8145?
How severe is CVE-2026-8145?
How do I fix CVE-2026-8145?
How Strix Helps
- How Strix found a critical auth bypass in etcdStrix autonomously discovered a critical authentication bypass in etcd, later designated CVE-2026-33413.
- Autonomous PentestingAI agents that find and validate exploitable vulnerabilities like this one across your applications.
- PR ReviewsPentest every pull request so vulnerable code is caught before it ships to production.
- AI Penetration TestingHow AI-driven penetration testing continuously covers your attack surface.
Related CVEs from 2026
- CVE-2026-81441Dell OpenManage Server Administrator, versions prior to 11.1…5.5
- CVE-2026-81442Dell OpenManage Server Administrator, versions prior to 11.1…8.1
- CVE-2026-81443Dell OpenManage Server Administrator, versions prior to 11.1…6.4
- CVE-2026-81445Dell OpenManage Server Administrator, versions prior to 11.1…7.2
- CVE-2026-81446Dell OpenManage Server Administrator, versions prior to 11.1…7.4
- CVE-2026-81447Dell OpenManage Server Administrator, versions prior to 11.1…6.8
- CVE-2026-81452Dell Alienware Command Center (AWCC), versions prior to 6.14…7
- CVE-2026-81453Dell OpenManage Server Administrator, versions prior to 11.1…6.5
- CVE-2026-81455Dell ThinOS 10, versions prior to SecurityAddon_2605.10.2766…8.6
- CVE-2026-81467Dell ThinOS 10, versions prior to 2605_10. 2616, contains an…9.8
- CVE-2026-81468Dell ThinOS 10, versions prior to 2605_10. 2616, contains an…7.2
- CVE-2026-81469Dell Inventory Collector Client, versions prior to 15.0.0, c…7.8
Are you affected by CVE-2026-8145?
Run a free Strix scan to check your systems for this vulnerability.
Scan your code nowSource: NVD / NIST
