CVE-2026-84188
Last modified
CVE-2026-84188 is a medium-severity vulnerability rated 4.8/10 on the CVSS scale. LibreNMS versions <= 26.4.0 contain a stored cross-site scripting vulnerability in the graph_descr.<graphtype> configuration settings, which are echoed verbatim without HTML escaping in includes/html/pages/graphs.inc.php. An administrator can store a malicious HTML payload that executes in the browser of any authenticated user who views the affected graph type. EPSS estimates a 0.25% chance of exploitation in the next 30 days.
Description
LibreNMS versions <= 26.4.0 contain a stored cross-site scripting vulnerability in the graph_descr.<graphtype> configuration settings, which are echoed verbatim without HTML escaping in includes/html/pages/graphs.inc.php. An administrator can store a malicious HTML payload that executes in the browser of any authenticated user who views the affected graph type. The issue is fixed in version 26.7.0.
Metrics
Weakness Enumeration
Affected Software
Source: CNA advisory (CVE.org). NVD analysis pending.
| Vendor | Product | Versions |
|---|---|---|
| librenms | librenms | < 26.7.0 |
References
Timeline
- Published
- Last Modified
- Status
- Deferred
Frequently Asked Questions
What is CVE-2026-84188?
How severe is CVE-2026-84188?
How do I fix CVE-2026-84188?
How Strix Helps
- How Strix found a critical auth bypass in etcdStrix autonomously discovered a critical authentication bypass in etcd, later designated CVE-2026-33413.
- Autonomous PentestingAI agents that find and validate exploitable vulnerabilities like this one across your applications.
- PR ReviewsPentest every pull request so vulnerable code is caught before it ships to production.
- AI Penetration TestingHow AI-driven penetration testing continuously covers your attack surface.
Related CVEs from 2026
- CVE-2026-8418The Games Catalog plugin for WordPress is vulnerable to Cros…4.3
- CVE-2026-84180Generation of Error Message Containing Sensitive Information…5.3
- CVE-2026-84181Improper Authentication vulnerability in Apache Camel Shiro …5.9
- CVE-2026-84185A flaw was found in the jwcrypto library, which is used for …5.9
- CVE-2026-84186Vulnerability involving incorrect access control in the Tool…6.9
- CVE-2026-84187AVideo contains a missing authentication vulnerability in pl…8.2
- CVE-2026-84189LibreNMS through 26.4.0 renders JSON fields (name, ip, model…8.1
- CVE-2026-8419The Amazon Scraper plugin for WordPress is vulnerable to Cro…4.3
- CVE-2026-84190LibreNMS versions before 26.5.0 contain a remote code execut…7.2
- CVE-2026-84191LibreNMS before 26.5.0 contains stored cross-site scripting …6.1
- CVE-2026-84192LibreNMS before 26.3.1 contains a stored cross-site scriptin…7.1
- CVE-2026-84193LibreNMS through 26.2.0 contains a stored cross-site scripti…5.8
Are you affected by CVE-2026-84188?
Run a free Strix scan to check your systems for this vulnerability.
Scan your code nowSource: NVD / NIST
