CVE-2026-85254
Last modified
CVE-2026-85254 is a medium-severity vulnerability rated 6.5/10 on the CVSS scale. Improper Handling of Case Sensitivity vulnerability in Apache Camel Platform HTTP component. This issue affects Apache Camel: from 4.0.0 before 4.18.5, from 4.19.0 before 4.22.1. The guard that prevents a request header being reflected into the response compared header names case sensitively, while HTTP header names are case insensitive. A caller could therefore defeat the suppression simply by varying the case of the header name. EPSS estimates a 0.34% chance of exploitation in the next 30 days.
Description
Improper Handling of Case Sensitivity vulnerability in Apache Camel Platform HTTP component. This issue affects Apache Camel: from 4.0.0 before 4.18.5, from 4.19.0 before 4.22.1. The guard that prevents a request header being reflected into the response compared header names case sensitively, while HTTP header names are case insensitive. A caller could therefore defeat the suppression simply by varying the case of the header name. HTTP/2 makes the problem unconditional rather than optional: the protocol requires header names to be lowercase on the wire, so the comparison never matched and the suppression was inert for every request on an HTTP/2 connection. The consequence is that content the caller chose is echoed back in the response, which is the basis for response-splitting and cache-poisoning style attacks against whatever sits in front of the Camel endpoint. Upgrade to Apache Camel 4.23.0, which fixes the issue. Users on the 4.18.x LTS releases stream should upgrade to 4.18.5. Users on the 4.22.x LTS releases stream should upgrade to 4.22.1. Request header names are now compared case insensitively, so the suppression holds regardless of casing and works under HTTP/2. For deployments that cannot upgrade immediately, strip the headers in question in front of the Camel endpoint, or remove them from the response in the route rather than relying on the built-in suppression.
Metrics
Weakness Enumeration
Affected Software
| Vendor | Product | Versions |
|---|---|---|
| Apache | Camel | >= 4.0.0, < 4.18.5 |
| Apache | Camel | >= 4.19.0, < 4.22.1 |
References
- https://camel.apache.org/security/CVE-2026-85254.htmlMitigation, Patch, Vendor Advisory
- https://github.com/apache/camel/pull/25831Issue Tracking, Patch
- https://github.com/apache/camel/pull/25940Issue Tracking, Patch
- https://github.com/apache/camel/pull/25942Issue Tracking, Patch
- https://issues.apache.org/jira/browse/CAMEL-24453Issue Tracking, Vendor Advisory
Timeline
- Published
- Last Modified
- Status
- Analyzed
Frequently Asked Questions
What is CVE-2026-85254?
How severe is CVE-2026-85254?
How do I fix CVE-2026-85254?
How Strix Helps
- How Strix found a critical auth bypass in etcdStrix autonomously discovered a critical authentication bypass in etcd, later designated CVE-2026-33413.
- Autonomous PentestingAI agents that find and validate exploitable vulnerabilities like this one across your applications.
- PR ReviewsPentest every pull request so vulnerable code is caught before it ships to production.
- AI Penetration TestingHow AI-driven penetration testing continuously covers your attack surface.
Related CVEs from 2026
- CVE-2026-85247Improper Certificate Validation vulnerability in Apache Came…5.9
- CVE-2026-85248Concurrent Execution using Shared Resource with Improper Syn…5.9
- CVE-2026-85249Improper Input Validation vulnerability in Apache Camel Tika…6.5
- CVE-2026-8525Heap buffer overflow in ANGLE in Google Chrome on Mac prior …8.3
- CVE-2026-85250Improper Restriction of XML External Entity Reference vulner…7.5
- CVE-2026-85251Exposure of Sensitive Information to an Unauthorized Actor v…7.5
- CVE-2026-85257Generation of Error Message Containing Sensitive Information…5.3
- CVE-2026-8526Out of bounds write in WebRTC in Google Chrome prior to 148.…8.8
- CVE-2026-85260Insertion of Sensitive Information into Log File vulnerabili…5.5
- CVE-2026-85267A Cross-Site WebSocket Hijacking vulnerability in Cloud Shel…8.7
- CVE-2026-85268A Cross-Site Scripting (XSS) (CWE-79) vulnerability in the a…8.7
- CVE-2026-8527Insufficient validation of untrusted input in Downloads in G…8.8
Are you affected by CVE-2026-85254?
Run a free Strix scan to check your systems for this vulnerability.
Scan your code nowSource: NVD / NIST
