CVE-2026-85979
Last modified
CVE-2026-85979 is a high-severity vulnerability rated 8.6/10 on the CVSS scale. Affected versions of Puppet Enterprise contain a command injection vulnerability. An authenticated user with Puppet administrative privileges can inject arbitrary shell commands by providing a specially crafted value for this parameter, which is passed to a shell execution context without sufficient sanitization. EPSS estimates a 0.97% chance of exploitation in the next 30 days.
Description
Affected versions of Puppet Enterprise contain a command injection vulnerability. An authenticated user with Puppet administrative privileges can inject arbitrary shell commands by providing a specially crafted value for this parameter, which is passed to a shell execution context without sufficient sanitization. Because the resulting commands are executed with root privileges, successful exploitation can lead to full compromise of the affected system. It affects Puppet Enterprise 2023.8.0 through 2023.8.10 and Puppet Enterprise 2025.0.0 through 2025.11.2. This has been resolved in Puppet Enterprise 2023.8.11 and Puppet Enterprise 2025.11.3.
Metrics
Weakness Enumeration
Affected Software
Source: CNA advisory (CVE.org). NVD analysis pending.
| Vendor | Product | Versions |
|---|---|---|
| Perforce Software | Puppet Enterprise | >= 2023.8.0, <= 2023.8.10; >= 2025.0.0, <= 2025.11.2 |
References
Timeline
- Published
- Last Modified
- Status
- Awaiting Analysis
Frequently Asked Questions
What is CVE-2026-85979?
How severe is CVE-2026-85979?
How do I fix CVE-2026-85979?
How Strix Helps
- How Strix found a critical auth bypass in etcdStrix autonomously discovered a critical authentication bypass in etcd, later designated CVE-2026-33413.
- Autonomous PentestingAI agents that find and validate exploitable vulnerabilities like this one across your applications.
- PR ReviewsPentest every pull request so vulnerable code is caught before it ships to production.
- AI Penetration TestingHow AI-driven penetration testing continuously covers your attack surface.
Related CVEs from 2026
- CVE-2026-85973Progress MarkLogic Server 12.x releases before 12.1.0 may us…7.4
- CVE-2026-85974Progress MarkLogic Server 12.x releases before 12.1.0 and 11…7.4
- CVE-2026-85975Progress MarkLogic Server 12.x releases before 12.1.0 and 11…7.5
- CVE-2026-85976Progress MarkLogic Server 12.x releases before 12.1.0 and 11…5.4
- CVE-2026-85977A flaw was found in libtirpc. A remote attacker can exploit …5.3
- CVE-2026-85978An unauthenticated remote code execution vulnerability exist…9.8
- CVE-2026-8598An undocumented configuration export port is accessible on s…9.1
- CVE-2026-85981The administrative panel of the Auth0 AD/LDAP Connector (ver…6.7
- CVE-2026-85982The Auth0 AD/LDAP Connector is vulnerable to stored Cross-Si…9
- CVE-2026-85983The Auth0 AD/LDAP Connector improperly processes a configura…7.8
- CVE-2026-85984The miniOrange OTP Login, Verification and SMS Notifications…9.8
- CVE-2026-85985MariaDB server is a community developed fork of MySQL server…5.4
Are you affected by CVE-2026-85979?
Run a free Strix scan to check your systems for this vulnerability.
Scan your code nowSource: NVD / NIST
