CVE-2026-8677
Last modified
CVE-2026-8677 is a medium-severity vulnerability rated 6.4/10 on the CVSS scale. The Prime Elementor Addons – Lightweight Elementor Widgets for Faster Pages plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Widget HTML Tag Settings in all versions up to, and including, 1.3.3 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. EPSS estimates a 0.24% chance of exploitation in the next 30 days.
Description
The Prime Elementor Addons – Lightweight Elementor Widgets for Faster Pages plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Widget HTML Tag Settings in all versions up to, and including, 1.3.3 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The exploit succeeds even for users without the unfiltered_html capability because the payload (e.g., 'img src=x onerror=alert(document.domain)') contains no HTML angle brackets and therefore passes through Elementor's wp_kses_post() filter unchanged at save time.
Metrics
Weakness Enumeration
References
Timeline
- Published
- Last Modified
- Status
- Deferred
Frequently Asked Questions
What is CVE-2026-8677?
How severe is CVE-2026-8677?
How do I fix CVE-2026-8677?
How Strix Helps
- How Strix found a critical auth bypass in etcdStrix autonomously discovered a critical authentication bypass in etcd, later designated CVE-2026-33413.
- Autonomous PentestingAI agents that find and validate exploitable vulnerabilities like this one across your applications.
- PR ReviewsPentest every pull request so vulnerable code is caught before it ships to production.
- AI Penetration TestingHow AI-driven penetration testing continuously covers your attack surface.
Related CVEs from 2026
- CVE-2026-86764Snipe-IT through 8.6.4 (fixed in 8.7.0) does not enforce the…6.5
- CVE-2026-86765Snipe-IT versions before 8.7.0 fail to enforce checkout auth…6.5
- CVE-2026-86766Snipe-IT versions up to and including 8.6.3 contain a race c…6.5
- CVE-2026-86767Snipe-IT versions before 8.7.0 fail to apply company scope f…5
- CVE-2026-86768Snipe-IT before 8.7.0 fails to validate soft-deleted state i…5.4
- CVE-2026-86769Snipe-IT versions before 8.7.0 contain an improper ownership…4.3
- CVE-2026-86770Snipe-IT before 8.7.0 fails to validate username case sensit…8.1
- CVE-2026-86771Snipe-IT versions before 8.7.0 fail to HTML-escape the emplo…7.6
- CVE-2026-86772Snipe-IT versions before 8.7.0 contain a stored cross-site s…5.4
- CVE-2026-86773Snipe-IT through version 8.6.3 fails to perform object-level…5.4
- CVE-2026-86774Snipe-IT versions before 8.7.0 contain a broken access contr…6.3
- CVE-2026-86775knowns (npm package) versions <= 0.29.1 contain a path trave…8.6
Are you affected by CVE-2026-8677?
Run a free Strix scan to check your systems for this vulnerability.
Scan your code nowSource: NVD / NIST
