CVE-2026-86819
Last modified
CVE-2026-86819 is a high-severity vulnerability rated 7.1/10 on the CVSS scale. Waves Central for macOS contains a local privilege escalation in the privileged helper service. The helper authorizes connecting XPC clients by comparing the caller's code-signing certificate chain for equality with its own, rather than validating the caller against a pinned code requirement (application identifier and Team ID). EPSS estimates a 0.07% chance of exploitation in the next 30 days.
Description
Waves Central for macOS contains a local privilege escalation in the privileged helper service. The helper authorizes connecting XPC clients by comparing the caller's code-signing certificate chain for equality with its own, rather than validating the caller against a pinned code requirement (application identifier and Team ID). A local, authenticated user can execute code within the vendor-signed process, satisfy the helper's client check, and cause the helper to execute a script with root privileges. Fixed in 17.0.
Metrics
Weakness Enumeration
Affected Software
Source: CNA advisory (CVE.org). NVD analysis pending.
| Vendor | Product | Versions |
|---|---|---|
| Waves Audio Ltd. | Waves Central | >= 16.6.2, < 17.0 |
References
Timeline
- Published
- Last Modified
- Status
- Awaiting Analysis
Frequently Asked Questions
What is CVE-2026-86819?
How severe is CVE-2026-86819?
How do I fix CVE-2026-86819?
How Strix Helps
- Uncovering a hidden BOLA in Appsmith's snapshot logicStrix autonomously discovered a BOLA/IDOR vulnerability in Appsmith's snapshot deletion path.
- Autonomous PentestingAI agents that find and validate exploitable vulnerabilities like this one across your applications.
- PR ReviewsPentest every pull request so vulnerable code is caught before it ships to production.
- AI Penetration TestingHow AI-driven penetration testing continuously covers your attack surface.
Related CVEs from 2026
- CVE-2026-86813The MetForm WordPress plugin before 4.1.9 does not properly …4.8
- CVE-2026-86814The UsersWP WordPress plugin before 1.5.10 does not verify …8.1
- CVE-2026-86815The BackWPup WordPress plugin before 5.7.5 does not properl…5.5
- CVE-2026-86816The WPCafe WordPress plugin before 3.0.21 does not restrict…5.3
- CVE-2026-86817The Five Star Business Profile and Schema WordPress plugin b…4.9
- CVE-2026-86818fast-uri is a dependency-free RFC 3986 URI parser for Node.j…4.8
- CVE-2026-8682The 3D Viewer – 3D Model Viewer – Augmented Reality – Virtua…4.3
- CVE-2026-86823The Newsletter WordPress plugin before 9.3.7 does not valid…5.3
- CVE-2026-86824The Newsletter WordPress plugin before 9.3.8 does not gener…4.8
- CVE-2026-86826The BackWPup WordPress plugin before 5.7.7 does not properl…5.9
- CVE-2026-86827The BackWPup WordPress plugin before 5.7.7 does not verify …5.3
- CVE-2026-86828The BackWPup WordPress plugin before 5.7.7 does not properl…6.6
Are you affected by CVE-2026-86819?
Run a free Strix scan to check your systems for this vulnerability.
Scan your code nowSource: NVD / NIST
