CVE-2026-88809
Last modified
CVE-2026-88809 is a high-severity vulnerability rated 7.6/10 on the CVSS scale. A security vulnerability exists in the SUSE Rancher Manager meta proxy endpoint (/meta/proxy). This endpoint is intended to forward requests only to destinations that appear on a configured allowlist.
Description
A security vulnerability exists in the SUSE Rancher Manager meta proxy endpoint (/meta/proxy). This endpoint is intended to forward requests only to destinations that appear on a configured allowlist. The allowlist decision was evaluated in a place where it could not stop a request from being forwarded, so a rejected destination was logged but the request was still handed to the proxy's transport. This affects SUSE Rancher 2.15.0 up to 2.15.3, 2.14.0 up to 2.14.7, 2.13.0 up to 2.13.11, 2.12.0 up to 2.12.15, 2.11.0 up to 2.11.19 and potentially older EOL versions.
Metrics
Weakness Enumeration
Affected Software
Source: CNA advisory (CVE.org). NVD analysis pending.
| Vendor | Product | Versions |
|---|---|---|
| SUSE | Rancher | >= 2.15.0, < 2.15.3; >= 2.14.0, < 2.14.7; >= 2.13.0, < 2.13.11; >= 2.12.0, < 2.12.15; >= 2.11.0, < 2.11.19 |
References
Timeline
- Published
- Last Modified
- Status
- Awaiting Analysis
Frequently Asked Questions
What is CVE-2026-88809?
How severe is CVE-2026-88809?
How do I fix CVE-2026-88809?
How Strix Helps
- One Click Account Takeover in GranolaHow a notification link broke out of Electron and led to a one-click account takeover.
- Autonomous PentestingAI agents that find and validate exploitable vulnerabilities like this one across your applications.
- PR ReviewsPentest every pull request so vulnerable code is caught before it ships to production.
- AI Penetration TestingHow AI-driven penetration testing continuously covers your attack surface.
Related CVEs from 2026
- CVE-2026-88802The MDJM Event Management WordPress plugin before 1.7.8.5 an…7.5
- CVE-2026-88804An unauthenticated update of public UI settings could be use…9.6
- CVE-2026-88805Incorrect credential cleaning on logout could be used by rem…8.1
- CVE-2026-88806A malicious X server could exploit a buffer overflow in libX…7.5
- CVE-2026-88807A heap overflow in libXrender before 0.9.13 in RenderQueryPi…8.9
- CVE-2026-88808A vulnerability has been identified within Rancher Manager w…8.8
- CVE-2026-8881Version 3.0.7 of the Securly Chrome Extension uses EVP_Bytes…7.5
- CVE-2026-88810A privilege escalation issue was discovered in Rancher Manag…7.2
- CVE-2026-88811Missing filtering in the SUSE Rancher Manager meta proxy cou…9.1
- CVE-2026-88812A double free in XKB SetGeometryin X.Org X Server before 21.…7.8
- CVE-2026-88815DBI versions before 1.654 for Perl incorrectly treat numeric…6.2
- CVE-2026-88816DBI versions before 1.654 for Perl incorrectly treat numeric…7.5
Are you affected by CVE-2026-88809?
Run a free Strix scan to check your systems for this vulnerability.
Scan your code nowSource: NVD / NIST
