CVE-2026-88920
Last modified
CVE-2026-88920 is a critical-severity vulnerability rated 9.8/10 on the CVSS scale. An authentication bypass in the DOM security processor in Apache WSS4J allows unauthenticated remote attackers to forge authenticated SOAP messages via a crafted unsigned SAML sender-vouches assertion containing an attacker-controlled key. Users are recommended to upgrade to versions 4.0.2 or 3.0.6 or 2.4.4, which fix this issue.. EPSS estimates a 0.53% chance of exploitation in the next 30 days.
Description
An authentication bypass in the DOM security processor in Apache WSS4J allows unauthenticated remote attackers to forge authenticated SOAP messages via a crafted unsigned SAML sender-vouches assertion containing an attacker-controlled key. Users are recommended to upgrade to versions 4.0.2 or 3.0.6 or 2.4.4, which fix this issue.
Metrics
Weakness Enumeration
Affected Software
| Vendor | Product | Versions |
|---|---|---|
| Apache | Wss4j | < 2.4.4 |
| Apache | Wss4j | >= 3.0.0, < 3.0.6 |
| Apache | Wss4j | >= 4.0.0, < 4.0.2 |
References
- https://lists.apache.org/thread.html/grt43m3bgbzz0mk0cnho3rcybb1j01z9Mailing List, Vendor Advisory
- https://www.openwall.com/lists/oss-security/2026/09/30/10Mailing List, Third Party Advisory
Timeline
- Published
- Last Modified
- Status
- Analyzed
Frequently Asked Questions
What is CVE-2026-88920?
How severe is CVE-2026-88920?
How do I fix CVE-2026-88920?
How Strix Helps
- How Strix found a critical auth bypass in etcdStrix autonomously discovered a critical authentication bypass in etcd, later designated CVE-2026-33413.
- Autonomous PentestingAI agents that find and validate exploitable vulnerabilities like this one across your applications.
- PR ReviewsPentest every pull request so vulnerable code is caught before it ships to production.
- AI Penetration TestingHow AI-driven penetration testing continuously covers your attack surface.
Related CVEs from 2026
- CVE-2026-88910The kboard WordPress plugin before 6.7 does not verify owner…5.3
- CVE-2026-88912The rtMedia for WordPress, BuddyPress and bbPress WordPress …4.2
- CVE-2026-88914A flaw was found in GStreamer's gst-plugins-good isomp4 plug…4.4
- CVE-2026-88915Affected versions of MISP do not consistently enforce the ac…7.1
- CVE-2026-88916Incorrect Authorization vulnerability in TÜBİTAK ULAKBİM Ula…6.8
- CVE-2026-8892The CM Business Directory – Optimise and showcase local busi…6.4
- CVE-2026-88921MISP contains an HTML injection vulnerability in the MISPEle…5.1
- CVE-2026-88922The go-getter library up to versions 1.8.8 and 2.2.3 is vuln…6.7
- CVE-2026-88924A flaw was found in the admin backend of gvfs. The privilege…7
- CVE-2026-88926The VikRentItems Flexible Rental Management System WordPress…8.6
- CVE-2026-88927The rtMedia for WordPress, BuddyPress and bbPress WordPress …4.3
- CVE-2026-88928The PAYCOMET for WooCommerce WordPress plugin before 5.46 do…6.5
Are you affected by CVE-2026-88920?
Run a free Strix scan to check your systems for this vulnerability.
Scan your code nowSource: NVD / NIST
