CVE-2026-92887
Last modified
CVE-2026-92887 is a vulnerability of currently unknown severity. Incorrect default value in the REST API framework's .rest.xml definition parser (ModelApiReader) in Apache OFBiz through 24.09.07 on all platforms allows a remote, unauthenticated attacker to invoke a REST API operation without providing valid credentials via a .rest.xml resource or operation definition that omits the auth attribute, which ModelApiReader incorrectly resolves to false instead of the true default declared by rest-api.xsd. Users are recommended to upgrade to version 24.09.08, which fixes this issue..
Description
Incorrect default value in the REST API framework's .rest.xml definition parser (ModelApiReader) in Apache OFBiz through 24.09.07 on all platforms allows a remote, unauthenticated attacker to invoke a REST API operation without providing valid credentials via a .rest.xml resource or operation definition that omits the auth attribute, which ModelApiReader incorrectly resolves to false instead of the true default declared by rest-api.xsd. Users are recommended to upgrade to version 24.09.08, which fixes this issue.
Weakness Enumeration
Affected Software
Source: CNA advisory (CVE.org). NVD analysis pending.
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache OFBiz | < 24.09.08 |
References
Timeline
- Published
- Last Modified
- Status
- Awaiting Analysis
Frequently Asked Questions
What is CVE-2026-92887?
How severe is CVE-2026-92887?
How do I fix CVE-2026-92887?
How Strix Helps
- How Strix found a critical auth bypass in etcdStrix autonomously discovered a critical authentication bypass in etcd, later designated CVE-2026-33413.
- Autonomous PentestingAI agents that find and validate exploitable vulnerabilities like this one across your applications.
- PR ReviewsPentest every pull request so vulnerable code is caught before it ships to production.
- AI Penetration TestingHow AI-driven penetration testing continuously covers your attack surface.
Related CVEs from 2026
- CVE-2026-92880A weakness has been identified in vgmstream up to r2117. Imp…6.3
- CVE-2026-92881A security vulnerability has been detected in vgmstream. The…4.3
- CVE-2026-92882Insufficiently protected credentials in the host and folder …5.3
- CVE-2026-92883GitLab has remediated an issue in GitLab CE/EE affecting all…8.7
- CVE-2026-92885The Qode Membership plugin for WordPress is vulnerable to Au…9.8
- CVE-2026-92886Missing Authorization vulnerability in TÜBİTAK BİLGEM Softwa…7.8
- CVE-2026-9289The WordLift – AI powered SEO – Schema plugin for WordPress …5.3
- CVE-2026-92892Potential arbitrary code execution under specific configurat…9
- CVE-2026-92893A flaw was found in the foreman_ansible plugin's Ansible inv…4.3
- CVE-2026-92894A flaw was found in the foreman_ansible plugin's Ansible ove…4.3
- CVE-2026-92895The Live2DWebCanvas plugin for WordPress is vulnerable to Ar…8.1
- CVE-2026-92899Apache WSS4J remembers the Nonce of each UsernameToken it ac…4.8
Are you affected by CVE-2026-92887?
Run a free Strix scan to check your systems for this vulnerability.
Scan your code nowSource: NVD / NIST
