CVE-2026-93589
Last modified
CVE-2026-93589 is a high-severity vulnerability rated 7.5/10 on the CVSS scale. ImageMagick before 7.1.2-31 and 6.9.13-56 contains a division-by-zero flaw in the FLIF encoder. An incorrect value for ticks per second in the image being encoded causes a divide-by-zero and crashes the encoder, resulting in a denial of service. EPSS estimates a 0.34% chance of exploitation in the next 30 days.
Description
ImageMagick before 7.1.2-31 and 6.9.13-56 contains a division-by-zero flaw in the FLIF encoder. An incorrect value for ticks per second in the image being encoded causes a divide-by-zero and crashes the encoder, resulting in a denial of service. The issue is fixed in 7.1.2-31 and 6.9.13-56.
Metrics
Weakness Enumeration
Affected Software
| Vendor | Product | Versions |
|---|---|---|
| Imagemagick | Imagemagick | < 6.9.13-56 |
| Imagemagick | Imagemagick | >= 7.0.0-0, < 7.1.2-31 |
References
Timeline
- Published
- Last Modified
- Status
- Analyzed
Frequently Asked Questions
What is CVE-2026-93589?
How severe is CVE-2026-93589?
How do I fix CVE-2026-93589?
How Strix Helps
- How Strix found a critical auth bypass in etcdStrix autonomously discovered a critical authentication bypass in etcd, later designated CVE-2026-33413.
- Autonomous PentestingAI agents that find and validate exploitable vulnerabilities like this one across your applications.
- PR ReviewsPentest every pull request so vulnerable code is caught before it ships to production.
- AI Penetration TestingHow AI-driven penetration testing continuously covers your attack surface.
Related CVEs from 2026
- CVE-2026-93580The InPost PL WordPress plugin before 1.9.8 does not verify …5.3
- CVE-2026-93581User-controlled values are not sufficiently neutralized when…6.1
- CVE-2026-93582The HTTP Basic Authentication modules in ((OTRS)) Community …9.4
- CVE-2026-93586ImageMagick before 7.1.2-31 and before 6.9.13-56 contains a …3.3
- CVE-2026-93587ImageMagick before 7.1.2-31 and before 6.9.13-56 contains a …3.3
- CVE-2026-93588ImageMagick before 7.1.2-31 and before 6.9.13-56 contains a …4.3
- CVE-2026-9359A vulnerability was identified in Edimax EW-7438RPn 1.28a. A…6.3
- CVE-2026-93590ImageMagick before 7.1.2-31 contains a policy bypass vulnera…7.5
- CVE-2026-93591SiYuan versions before 3.8.3 contain an SQL injection vulner…7.6
- CVE-2026-93592vLLM versions before 0.28.0 fail to validate the lower bound…7.5
- CVE-2026-93593ArcadeDB before 26.9.1 fails to enforce security-group types…8.1
- CVE-2026-93594ArcadeDB (Maven artifact com.arcadedb:arcadedb-engine) throu…8.1
Are you affected by CVE-2026-93589?
Run a free Strix scan to check your systems for this vulnerability.
Scan your code nowSource: NVD / NIST
