CVE-2026-95663
Last modified
CVE-2026-95663 is a medium-severity vulnerability rated 6.5/10 on the CVSS scale. Insufficient Session Expiration vulnerability in Apache Camel Keycloak component. This issue affects Apache Camel: from 4.16.0 before 4.18.5, from 4.19.0 before 4.22.2. When token introspection is enabled on the camel-keycloak KeycloakSecurityPolicy (useTokenIntrospection=true), the security processor validates the access token of a request by sending it to Keycloak's OAuth 2.0 token introspection endpoint, and accepts the token while the response reports it as active. The introspection endpoint reports a token as inactive once its exp (expiration) time has passed, so on this path the active flag is what enforces token expiry. EPSS estimates a 0.24% chance of exploitation in the next 30 days.
Description
Insufficient Session Expiration vulnerability in Apache Camel Keycloak component. This issue affects Apache Camel: from 4.16.0 before 4.18.5, from 4.19.0 before 4.22.2. When token introspection is enabled on the camel-keycloak KeycloakSecurityPolicy (useTokenIntrospection=true), the security processor validates the access token of a request by sending it to Keycloak's OAuth 2.0 token introspection endpoint, and accepts the token while the response reports it as active. The introspection endpoint reports a token as inactive once its exp (expiration) time has passed, so on this path the active flag is what enforces token expiry. Introspection results are cached by default (introspectionCacheEnabled=true, introspectionCacheTtl=60 seconds), and both cache implementations shipped with the component, ConcurrentMapTokenCache and CaffeineTokenCache, expired an entry a fixed time after it was inserted, without bounding that lifetime by the exp claim that the cached response already carried. KeycloakSecurityProcessor in turn checked only the active flag of the result, on every path that uses introspection, and never compared exp with the current time. A response cached shortly before the token expired was therefore served to later requests carrying the same token for up to the configured time-to-live after the token's expiry, and those requests were admitted with the roles and permissions the expired token had carried, although RFC 7662, which defines token introspection, states that a response containing exp must not be cached beyond that time. The access token is supplied by the caller with each request, typically as a bearer token in the Authorization header, so a caller holding a token that was valid moments earlier could keep using it after it expired, for as long as the cached entry lived. The window is bounded by introspectionCacheTtl, which is 60 seconds by default and 300 to 600 seconds where the documentation's recommendation for internal services was followed, and it opens only for a token that the same Camel process introspected and cached while the token was still active. The issue grants nothing beyond what the token already carried: it allows no token forgery and no privilege escalation, and token introspection is not enabled by default, which is why the severity is assessed medium. The local JWT verification path, used when introspection is disabled, is not affected by this issue. Users are recommended to upgrade to version 4.23.0, which fixes the issue. If users are on the 4.22.x releases stream, then they are suggested to upgrade to 4.22.2. If users are on the 4.18.x releases stream, then they are suggested to upgrade to 4.18.5. The 4.16.x, 4.17.x and 4.19.x to 4.21.x release lines reached end of life before this issue was resolved and will not receive a fix, so deployments on them must move to a supported release. For deployments that cannot upgrade immediately, set introspectionCacheEnabled=false on the KeycloakSecurityPolicy, so that every request is checked against the introspection endpoint, which reports an expired token as inactive, at the cost of one introspection call per request. Lowering introspectionCacheTtl only narrows the window and does not close it.
Metrics
Weakness Enumeration
Affected Software
| Vendor | Product | Versions |
|---|---|---|
| Apache | Camel | >= 4.16.0, < 4.18.5 |
| Apache | Camel | >= 4.19.0, < 4.22.2 |
References
- https://camel.apache.org/security/CVE-2026-46455.htmlNot Applicable
- https://camel.apache.org/security/CVE-2026-85301.htmlNot Applicable
- https://camel.apache.org/security/CVE-2026-95663.htmlVendor Advisory
- https://github.com/apache/camel/pull/26747Issue Tracking, Patch
- https://github.com/apache/camel/pull/27182Issue Tracking, Patch
- https://github.com/apache/camel/pull/27183Issue Tracking, Patch
- https://issues.apache.org/jira/browse/CAMEL-24902Issue Tracking, Vendor Advisory
Timeline
- Published
- Last Modified
- Status
- Analyzed
Frequently Asked Questions
What is CVE-2026-95663?
How severe is CVE-2026-95663?
How do I fix CVE-2026-95663?
How Strix Helps
- How Strix found a critical auth bypass in etcdStrix autonomously discovered a critical authentication bypass in etcd, later designated CVE-2026-33413.
- Autonomous PentestingAI agents that find and validate exploitable vulnerabilities like this one across your applications.
- PR ReviewsPentest every pull request so vulnerable code is caught before it ships to production.
- AI Penetration TestingHow AI-driven penetration testing continuously covers your attack surface.
Related CVEs from 2026
- CVE-2026-95658MISP's WorkflowsController exposed the moduleStatelessExecut…6.9
- CVE-2026-95659MISP contains a reflected cross-site scripting (XSS) vulnera…4.8
- CVE-2026-9566A vulnerability was identified in teableio teable up to 1.9.…4.3
- CVE-2026-95660A security flaw has been discovered in Moonshot AI Kimi Code…6.3
- CVE-2026-95661MISP contains a reflected cross-site scripting (XSS) vulnera…5.1
- CVE-2026-95662Cross-Site Scripting vulnerability in the Repasat applicatio…4.8
- CVE-2026-95664Improper Neutralization of Special Elements used in an Expre…5.4
- CVE-2026-95665MISP contains a reflected cross-site scripting (XSS) vulnera…5.1
- CVE-2026-95666Mattermost versions 11.9.x <= 11.9.1, 11.8.x <= 11.8.5, 11.7…4.3
- CVE-2026-95667The MISP installer scripts (for Debian 12, Debian 13, Ubuntu…6.9
- CVE-2026-9567A security flaw has been discovered in GPAC up to 2.4.0. Aff…3.3
- CVE-2026-95670The No External Links plugin for WordPress is vulnerable to …7.2
Are you affected by CVE-2026-95663?
Run a free Strix scan to check your systems for this vulnerability.
Scan your code nowSource: NVD / NIST
