CVE-2026-95860
Last modified
CVE-2026-95860 is a critical-severity vulnerability rated 9.1/10 on the CVSS scale. node-opcua is an OPC UA implementation for TypeScript and Node.js. From 2.42.0 until 2.180.0, namespace-level access control configured through setDefaultRolePermissions is not honored by the runtime enforcement path for nodes without explicit per-node RolePermissions. EPSS estimates a 0.60% chance of exploitation in the next 30 days.
Description
node-opcua is an OPC UA implementation for TypeScript and Node.js. From 2.42.0 until 2.180.0, namespace-level access control configured through setDefaultRolePermissions is not honored by the runtime enforcement path for nodes without explicit per-node RolePermissions. SessionContext.getApplicableRolePermissions reads a missing or null DefaultRolePermissions metadata value instead of the configured namespace field, and the null result is treated permissively. An anonymous network client can consequently write variables with CurrentWrite access or call bound methods when an operator configured a restrictive namespace default and relied on inheritance. Servers with no declared policy, nodes with explicit per-node permissions, and correctly bound programmatic namespace metadata are outside the authorization-bypass case. This issue is fixed in version 2.180.0.
Metrics
Weakness Enumeration
References
Timeline
- Published
- Last Modified
- Status
- Deferred
Frequently Asked Questions
What is CVE-2026-95860?
How severe is CVE-2026-95860?
How do I fix CVE-2026-95860?
How Strix Helps
- Uncovering a hidden BOLA in Appsmith's snapshot logicStrix autonomously discovered a BOLA/IDOR vulnerability in Appsmith's snapshot deletion path.
- Autonomous PentestingAI agents that find and validate exploitable vulnerabilities like this one across your applications.
- PR ReviewsPentest every pull request so vulnerable code is caught before it ships to production.
- AI Penetration TestingHow AI-driven penetration testing continuously covers your attack surface.
Related CVEs from 2026
- CVE-2026-95846Moquette is a lightweight Java MQTT broker. Prior to 0.18.1,…7.5
- CVE-2026-95847Moquette is a lightweight Java MQTT broker. Prior to 0.18.1,…7.5
- CVE-2026-95848Moquette is a lightweight Java MQTT broker. Prior to 0.18.1,…9.1
- CVE-2026-9585An unauthenticated reflected cross-site scripting (XSS) vuln…8.6
- CVE-2026-95859libp2p-rust is the official Rust language implementation of …8.7
- CVE-2026-9586An unauthenticated SQL injection vulnerability exists in San…9.8
- CVE-2026-95861A malicious actor with access to the network could exploit a…7.5
- CVE-2026-95862A malicious actor with access to the network could exploit a…7.5
- CVE-2026-95863Improper neutralization of input during web page generation …7.6
- CVE-2026-95864The Themify Builder plugin for WordPress is vulnerable to St…7.2
- CVE-2026-95865The Beaver Builder Page Builder – Drag and Drop Website Buil…6.5
- CVE-2026-95866The User Profile Builder – Beautiful User Registration Forms…7.2
Are you affected by CVE-2026-95860?
Run a free Strix scan to check your systems for this vulnerability.
Scan your code nowSource: NVD / NIST
