CVE-2026-96405
Last modified
CVE-2026-96405 is a medium-severity vulnerability rated 5.3/10 on the CVSS scale. NLnet Labs Unbound up to and including version 1.26.1 limits compression-pointer traversal for each individual domain-name operation but has no aggregate inbound decompression-work budget. Many chained compression pointers in a message results in a lot of CPU usage following them. EPSS estimates a 0.25% chance of exploitation in the next 30 days.
Description
NLnet Labs Unbound up to and including version 1.26.1 limits compression-pointer traversal for each individual domain-name operation but has no aggregate inbound decompression-work budget. Many chained compression pointers in a message results in a lot of CPU usage following them. A malicious actor with recursive-query access and control of an ordinarily delegated authority that serves specially crafted replies can exploit the vulnerability and degrade Unbound's general performance.
Metrics
Weakness Enumeration
Affected Software
Source: CNA advisory (CVE.org). NVD analysis pending.
| Vendor | Product | Versions |
|---|---|---|
| NLnet Labs | Unbound | < 1.26.2 |
References
Timeline
- Published
- Last Modified
- Status
- Awaiting Analysis
Frequently Asked Questions
What is CVE-2026-96405?
How severe is CVE-2026-96405?
How do I fix CVE-2026-96405?
How Strix Helps
- How Strix found a critical auth bypass in etcdStrix autonomously discovered a critical authentication bypass in etcd, later designated CVE-2026-33413.
- Autonomous PentestingAI agents that find and validate exploitable vulnerabilities like this one across your applications.
- PR ReviewsPentest every pull request so vulnerable code is caught before it ships to production.
- AI Penetration TestingHow AI-driven penetration testing continuously covers your attack surface.
Related CVEs from 2026
- CVE-2026-96398Incorrect Authorization vulnerability in Drupal Webform allo…4.3
- CVE-2026-96399A repository's external issue tracker regular expression con…7.5
- CVE-2026-9640A privilege escalation vulnerability exists in LXD from 6.0 …7.2
- CVE-2026-96400With `[migrations] ALLOWED_DOMAINS` set to a matching entry …4.3
- CVE-2026-96402A malicious USB MTP/PTP device can cause the USBX host to re…5.2
- CVE-2026-96404When Gitea's web installer is reachable against a database t…8.1
- CVE-2026-96406A VideoStreaming interface reports the size of its whole cla…4.9
- CVE-2026-96408A code injection vulnerability exists in the upgrade script …9.3
- CVE-2026-9641Crypt::PBKDF2 versions before 0.261630 for Perl have a weak …5.3
- CVE-2026-96415Catapult DCT2000 protocol dissector crash in 4.6.0 to 4.6.8 …5.5
- CVE-2026-96416IEEE 802.11 protocol dissector crash in 4.6.0 to 4.6.8 and 4…5.5
- CVE-2026-96417RF4CE protocol dissector crash in 4.6.0 to 4.6.8 and 4.4.0 t…5.5
Are you affected by CVE-2026-96405?
Run a free Strix scan to check your systems for this vulnerability.
Scan your code nowSource: NVD / NIST
