CVE-2026-84314

HIGHCVSS 8.7/10EPSS 0.33%

Last modified

CVE-2026-84314 is a high-severity vulnerability rated 8.7/10 on the CVSS scale. Nginx UI is a web user interface for the Nginx web server. Prior to 2.4.1, the POST /api/users/:id user-management endpoint permits an authenticated user to change another user's password without passing RequireSecureSession, even though the self-service password-change path requires that step-up. EPSS estimates a 0.33% chance of exploitation in the next 30 days.

Description

Nginx UI is a web user interface for the Nginx web server. Prior to 2.4.1, the POST /api/users/:id user-management endpoint permits an authenticated user to change another user's password without passing RequireSecureSession, even though the self-service password-change path requires that step-up. An attacker with an authenticated account can change the initial administrator's password, invalidate existing administrator tokens, and then authenticate as the administrator. This issue is fixed in version 2.4.1.

Metrics

Weakness Enumeration

Affected Software

Source: CNA advisory (CVE.org). NVD analysis pending.

VendorProductVersions
0xJackynginx-ui< 2.4.1

References

Timeline

Published
Last Modified
Status
Deferred

Frequently Asked Questions

What is CVE-2026-84314?
Nginx UI is a web user interface for the Nginx web server. Prior to 2.4.1, the POST /api/users/:id user-management endpoint permits an authenticated user to change another user's password without passing RequireSecureSession, even though the self-service password-change path requires that step-up. An attacker with an authenticated account can change the initial administrator's password, invalidate existing administrator tokens, and then authenticate as the administrator. This issue is fixed in version 2.4.1.
How severe is CVE-2026-84314?
CVE-2026-84314 has a CVSS score of 8.7/10 (HIGH severity). The EPSS model estimates a 0.33% probability of exploitation in the next 30 days.
How do I fix CVE-2026-84314?
Check the vendor references and advisories linked above for patched versions and mitigation guidance. You can also run a Strix scan to test if your systems are affected.

How Strix Helps

Related CVEs from 2026

Are you affected by CVE-2026-84314?

Run a free Strix scan to check your systems for this vulnerability.

Scan your code now

Source: NVD / NIST