CVE-2026-86589
Last modified
CVE-2026-86589 is a medium-severity vulnerability rated 5.4/10 on the CVSS scale. Incorrect implementation of authentication algorithm vulnerability in Apache Answer. This issue affects Apache Answer: through 2.0.2. A flaw in the User Center login integration can cause a newly created external user session to omit its external identity, allowing subsequent requests to bypass central account suspension or deletion checks until the session expires or is revoked. Users are recommended to upgrade to version 2.0.3, which fixes the issue.. EPSS estimates a 0.24% chance of exploitation in the next 30 days.
Description
Incorrect implementation of authentication algorithm vulnerability in Apache Answer. This issue affects Apache Answer: through 2.0.2. A flaw in the User Center login integration can cause a newly created external user session to omit its external identity, allowing subsequent requests to bypass central account suspension or deletion checks until the session expires or is revoked. Users are recommended to upgrade to version 2.0.3, which fixes the issue.
Metrics
Weakness Enumeration
Affected Software
Source: CNA advisory (CVE.org). NVD analysis pending.
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Answer | <= 2.0.2 |
References
Timeline
- Published
- Last Modified
- Status
- Deferred
Frequently Asked Questions
What is CVE-2026-86589?
How severe is CVE-2026-86589?
How do I fix CVE-2026-86589?
How Strix Helps
- How Strix found a critical auth bypass in etcdStrix autonomously discovered a critical authentication bypass in etcd, later designated CVE-2026-33413.
- Autonomous PentestingAI agents that find and validate exploitable vulnerabilities like this one across your applications.
- PR ReviewsPentest every pull request so vulnerable code is caught before it ships to production.
- AI Penetration TestingHow AI-driven penetration testing continuously covers your attack surface.
Related CVEs from 2026
- CVE-2026-86575Stack-based Buffer Overflow Vulnerability in JP1 Products. …9.4
- CVE-2026-86576Heap-based Buffer Overflow Vulnerability in JP1 Products. T…9.4
- CVE-2026-86577Out-of-bounds Write Vulnerability in JP1 Products. This iss…9.4
- CVE-2026-8658OS Command Injection vulnerability in Rapid7 InsightConnect …8.8
- CVE-2026-86583The Import and export users and customers plugin for WordPre…8.8
- CVE-2026-86585The lack of signature verification of firmware update packag…7.7
- CVE-2026-8659OS Command Injection vulnerability in Rapid7 InsightConnect …8.8
- CVE-2026-86590In Eclipse Che versions 7.79.0 through 7.121.0, the dashboar…6.3
- CVE-2026-86591The Botiga Pro WordPress plugin before 1.6.5 does not perfor…9.8
- CVE-2026-86595Improper neutralization of special elements used in an SQL c…8.8
- CVE-2026-86597Insertion of sensitive information into log files in the Sno…6.5
- CVE-2026-8660OS Command Injection vulnerability in the ping action of Rap…9.8
Are you affected by CVE-2026-86589?
Run a free Strix scan to check your systems for this vulnerability.
Scan your code nowSource: NVD / NIST
