CVE-2026-86597
Last modified
CVE-2026-86597 is a medium-severity vulnerability rated 6.5/10 on the CVSS scale. Insertion of sensitive information into log files in the Snowflake Python, Go, JDBC, Node.js, PHP PDO, and ODBC drivers allowed authentication tokens, query-result encryption keys, pre-signed cloud-storage URLs, and SAML assertions to be written to diagnostic logs in circumstances where the available log redaction did not cover all affected log paths and data types. An attacker with read access to the log destination, whether the local filesystem, a log aggregation service, or a CI/CD artifact store, could obtain credentials and decryption keys that, if still valid at the time of access, could be used to authenticate to the corresponding Snowflake account or cloud-storage object. EPSS estimates a 0.09% chance of exploitation in the next 30 days.
Description
Insertion of sensitive information into log files in the Snowflake Python, Go, JDBC, Node.js, PHP PDO, and ODBC drivers allowed authentication tokens, query-result encryption keys, pre-signed cloud-storage URLs, and SAML assertions to be written to diagnostic logs in circumstances where the available log redaction did not cover all affected log paths and data types. An attacker with read access to the log destination, whether the local filesystem, a log aggregation service, or a CI/CD artifact store, could obtain credentials and decryption keys that, if still valid at the time of access, could be used to authenticate to the corresponding Snowflake account or cloud-storage object. Successful exploitation requires read access to the log destination, and impact is bounded by credential lifetime and object scope. The fix is available in Snowflake Connector for Python v4.7.3, Snowflake Go Driver v2.2.0, Snowflake JDBC Driver v4.3.4 (including the snowflake-jdbc-fips and snowflake-jdbc-thin), Snowflake Node.js Driver v3.3.0, Snowflake PHP PDO Driver v4.2.0, and Snowflake ODBC Driver v3.20.0. Users must manually upgrade and should securely delete previously generated diagnostic logs containing sensitive information where retention is not required.
Metrics
Weakness Enumeration
Affected Software
Source: CNA advisory (CVE.org). NVD analysis pending.
| Vendor | Product | Versions |
|---|---|---|
| Snowflake | Snowflake Connector for Python | < 4.7.3 |
| Snowflake | Snowflake Go Driver | <= 1.19.1 |
| Snowflake | Snowflake Go Driver | >= 2.0.0, < 2.2.0 |
| Snowflake | Snowflake JDBC Driver | < 4.3.4 |
| Snowflake | Snowflake JDBC Driver (FIPS) | < 4.3.4 |
| Snowflake | Snowflake JDBC Driver (Thin) | < 4.3.4 |
| Snowflake | Snowflake Node.js Driver | < 3.3.0 |
| Snowflake | Snowflake PHP PDO Driver | >= 3.4.0, < 4.2.0 |
| Snowflake | Snowflake ODBC Driver | >= 3.16.0, < 3.20.0 |
References
Timeline
- Published
- Last Modified
- Status
- Awaiting Analysis
Frequently Asked Questions
What is CVE-2026-86597?
How severe is CVE-2026-86597?
How do I fix CVE-2026-86597?
How Strix Helps
- How Strix found a critical auth bypass in etcdStrix autonomously discovered a critical authentication bypass in etcd, later designated CVE-2026-33413.
- Autonomous PentestingAI agents that find and validate exploitable vulnerabilities like this one across your applications.
- PR ReviewsPentest every pull request so vulnerable code is caught before it ships to production.
- AI Penetration TestingHow AI-driven penetration testing continuously covers your attack surface.
Related CVEs from 2026
- CVE-2026-86585The lack of signature verification of firmware update packag…7.7
- CVE-2026-86589Incorrect implementation of authentication algorithm vulnera…5.4
- CVE-2026-8659OS Command Injection vulnerability in Rapid7 InsightConnect …8.8
- CVE-2026-86590In Eclipse Che versions 7.79.0 through 7.121.0, the dashboar…6.3
- CVE-2026-86591The Botiga Pro WordPress plugin before 1.6.5 does not perfor…9.8
- CVE-2026-86595Improper neutralization of special elements used in an SQL c…8.8
- CVE-2026-8660OS Command Injection vulnerability in the ping action of Rap…9.8
- CVE-2026-86600In affected Snowflake drivers, WORKLOAD_IDENTITY authenticat…8.2
- CVE-2026-86601The WP Recipe Maker WordPress plugin before 10.8.2 does not …6.5
- CVE-2026-86602The WP Recipe Maker WordPress plugin before 10.8.2 does not …4.3
- CVE-2026-86603The WP Recipe Maker WordPress plugin before 10.8.2 does not …4.3
- CVE-2026-86604The GTranslate WordPress plugin before 5.0.1 does not remove…4.8
Are you affected by CVE-2026-86597?
Run a free Strix scan to check your systems for this vulnerability.
Scan your code nowSource: NVD / NIST
