CVE-2026-95628
Last modified
CVE-2026-95628 is a medium-severity vulnerability rated 5.4/10 on the CVSS scale. Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in Apache Camel Docling component. This issue affects Apache Camel: from 4.15.0 before 4.18.5, from 4.19.0 before 4.22.2. DoclingProducer builds the command line of the external docling tool and appends to it the custom arguments supplied in the CamelDoclingCustomArguments header, a list of strings whose flags the fix for CVE-2026-40047 restricted to an allowlist. That fix also introduced validatePathSafety to keep path-like argument values inside the intended directory, but the method only looked for relative traversal: it rejected a value containing a traversal sequence such as ../ and a value whose normalized form still held a .. EPSS estimates a 0.34% chance of exploitation in the next 30 days.
Description
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in Apache Camel Docling component. This issue affects Apache Camel: from 4.15.0 before 4.18.5, from 4.19.0 before 4.22.2. DoclingProducer builds the command line of the external docling tool and appends to it the custom arguments supplied in the CamelDoclingCustomArguments header, a list of strings whose flags the fix for CVE-2026-40047 restricted to an allowlist. That fix also introduced validatePathSafety to keep path-like argument values inside the intended directory, but the method only looked for relative traversal: it rejected a value containing a traversal sequence such as ../ and a value whose normalized form still held a .. element. It never checked whether a value was an absolute path, and an absolute path without traversal segments contains neither, so it passed unchanged. Every path-like value went through this check, whether it was a separate list element following its flag or was attached to the flag after an equals sign, so an absolute path was accepted in either form, for example as the directory given to the allowlisted --artifacts-path flag, which tells docling where to find its model artifacts. Such a value reached the docling command line as given, so a party able to choose the custom arguments could point the docling process at any directory the Camel process can access, outside the working directory that the check was meant to keep path values in, which is the outcome the CVE-2026-40047 fix set out to prevent. Only the CLI mode, which is the default, passes custom arguments to docling. The header belongs to the Camel header namespace, which consumers applying Camel's default header filtering, such as the JMS and Kafka consumers, remove from incoming messages, so the issue is reached where a route forwards externally influenced values into the header or where a consumer maps incoming headers without that filtering. Users are recommended to upgrade to version 4.23.0, which fixes the issue. If users are on the 4.22.x releases stream, then they are suggested to upgrade to 4.22.2. If users are on the 4.18.x releases stream, then they are suggested to upgrade to 4.18.5. The 4.15.x to 4.17.x and 4.19.x to 4.21.x release lines reached end of life before this issue was resolved and will not receive a fix, so deployments on them must move to a supported release. For deployments that cannot upgrade immediately, do not build the CamelDoclingCustomArguments header from values that originate outside the deployment, remove that header from messages that arrive from outside before they reach a docling endpoint, and make sure that consumers which map incoming message headers drop the Camel header namespace, so that only the route itself chooses the custom arguments.
Metrics
Weakness Enumeration
Affected Software
Source: CNA advisory (CVE.org). NVD analysis pending.
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Camel | >= 4.15.0, < 4.18.5; >= 4.19.0, < 4.22.2 |
References
Timeline
- Published
- Last Modified
- Status
- Awaiting Analysis
Frequently Asked Questions
What is CVE-2026-95628?
How severe is CVE-2026-95628?
How do I fix CVE-2026-95628?
How Strix Helps
- How Strix found a critical auth bypass in etcdStrix autonomously discovered a critical authentication bypass in etcd, later designated CVE-2026-33413.
- Autonomous PentestingAI agents that find and validate exploitable vulnerabilities like this one across your applications.
- PR ReviewsPentest every pull request so vulnerable code is caught before it ships to production.
- AI Penetration TestingHow AI-driven penetration testing continuously covers your attack surface.
Related CVEs from 2026
- CVE-2026-95620A use-after-free vulnerability in the Qt QNetworkAccessManag…2.1
- CVE-2026-95623The Tauri HTTP plugin validates requested URLs against the a…5.6
- CVE-2026-95624The Tauri updater plugin's 'check' IPC command accepts an al…6.8
- CVE-2026-95625The Tauri updater plugin verifies update binaries using mini…5.9
- CVE-2026-95626Tauri's Content Security Policy hardening, which injects a r…8.3
- CVE-2026-95627When a Tauri application uses the dialog plugin's file or fo…7.7
- CVE-2026-95629Improper Limitation of a Pathname to a Restricted Directory …5.4
- CVE-2026-9563In Eclipse Parsson published Maven Central artifacts before …7.5
- CVE-2026-95630Adobe Commerce is affected by an Improper Input Validation v…4.3
- CVE-2026-95631Adobe Commerce is affected by an Improper Input Validation v…8.7
- CVE-2026-95632CAI Content Credentials is affected by an Improper Verificat…7.5
- CVE-2026-95633CAI Content Credentials is affected by an Improper Verificat…7.5
Are you affected by CVE-2026-95628?
Run a free Strix scan to check your systems for this vulnerability.
Scan your code nowSource: NVD / NIST
