CVE-2022-51023
Last modified
CVE-2022-51023 is a high-severity vulnerability rated 8.2/10 on the CVSS scale. PHPOK 4.5.000 before 5.4.081 contains an SQL injection vulnerability that allows unauthenticated attackers to manipulate ORDER BY clauses via the sort parameter. Attackers can send GET requests to /api.php?c=project&f=index with extractvalue payloads in sort to extract database information through error messages. EPSS estimates a 0.26% chance of exploitation in the next 30 days.
Description
PHPOK 4.5.000 before 5.4.081 contains an SQL injection vulnerability that allows unauthenticated attackers to manipulate ORDER BY clauses via the sort parameter. Attackers can send GET requests to /api.php?c=project&f=index with extractvalue payloads in sort to extract database information through error messages. Exploitation evidence was first observed by the Shadowserver Foundation on 2023-10-14.
Metrics
Weakness Enumeration
Affected Software
Source: CNA advisory (CVE.org). NVD analysis pending.
| Vendor | Product | Versions |
|---|---|---|
| PHPOK | PHPOK | >= 4.5.000, < 5.4.081 |
References
Timeline
- Published
- Last Modified
- Status
- Deferred
Frequently Asked Questions
What is CVE-2022-51023?
How severe is CVE-2022-51023?
How do I fix CVE-2022-51023?
How Strix Helps
- How Strix found a critical auth bypass in etcdStrix autonomously discovered a critical authentication bypass in etcd, later designated CVE-2026-33413.
- Autonomous PentestingAI agents that find and validate exploitable vulnerabilities like this one across your applications.
- PR ReviewsPentest every pull request so vulnerable code is caught before it ships to production.
- AI Penetration TestingHow AI-driven penetration testing continuously covers your attack surface.
Related CVEs from 2022
- CVE-2022-51017PocketMine-MP versions before 3.26.5 and 4.0.5 fail to valid…7.5
- CVE-2022-51018PocketMine-MP before 3.26.5 and 4.0.x before 4.0.5 does not …6.5
- CVE-2022-51019Akaunting before 2.1.31 contains an OS command injection vul…8.8
- CVE-2022-51020Flower before 2.2.0 contains a cross-site request forgery vu…5.9
- CVE-2022-51021NotificationX plugin for WordPress 2.0.0 before 2.3.12 conta…8.2
- CVE-2022-51022YiShaAdmin 2.2 through 3.1, fixed in commit 025b062, contain…9.1
- CVE-2022-51024Kavita 0.5.2 before 0.5.4.1 contains a path traversal vulner…7.5
- CVE-2022-51025Penta Security WAPPLES 4.0.54.1, 5.0, and 6.0 contains a pat…6.5
- CVE-2022-51026Bytebase 0.12.0 before 1.0.1 contains an authentication bypa…9.8
Are you affected by CVE-2022-51023?
Run a free Strix scan to check your systems for this vulnerability.
Scan your code nowSource: NVD / NIST
