CVE-2022-51025
Last modified
CVE-2022-51025 is a medium-severity vulnerability rated 6.5/10 on the CVSS scale. Penta Security WAPPLES 4.0.54.1, 5.0, and 6.0 contains a path traversal vulnerability that allows authenticated attackers to download arbitrary files via the name parameter of /webapi/file/transfer. Attackers can send GET requests with type=db_backup and ../ sequences in name to read files like /etc/passwd, and a hardcoded systemi account makes authentication effectively trivial. EPSS estimates a 0.37% chance of exploitation in the next 30 days.
Description
Penta Security WAPPLES 4.0.54.1, 5.0, and 6.0 contains a path traversal vulnerability that allows authenticated attackers to download arbitrary files via the name parameter of /webapi/file/transfer. Attackers can send GET requests with type=db_backup and ../ sequences in name to read files like /etc/passwd, and a hardcoded systemi account makes authentication effectively trivial. Exploitation evidence was first observed by the Shadowserver Foundation on 2023-10-19.
Metrics
Weakness Enumeration
Affected Software
Source: CNA advisory (CVE.org). NVD analysis pending.
| Vendor | Product | Versions |
|---|---|---|
| Penta Security Systems | WAPPLES | 4.0.54.1; 5.0; 6.0 |
References
Timeline
- Published
- Last Modified
- Status
- Deferred
Frequently Asked Questions
What is CVE-2022-51025?
How severe is CVE-2022-51025?
How do I fix CVE-2022-51025?
How Strix Helps
- How Strix found a critical auth bypass in etcdStrix autonomously discovered a critical authentication bypass in etcd, later designated CVE-2026-33413.
- Autonomous PentestingAI agents that find and validate exploitable vulnerabilities like this one across your applications.
- PR ReviewsPentest every pull request so vulnerable code is caught before it ships to production.
- AI Penetration TestingHow AI-driven penetration testing continuously covers your attack surface.
Related CVEs from 2022
- CVE-2022-51019Akaunting before 2.1.31 contains an OS command injection vul…8.8
- CVE-2022-51020Flower before 2.2.0 contains a cross-site request forgery vu…5.9
- CVE-2022-51021NotificationX plugin for WordPress 2.0.0 before 2.3.12 conta…8.2
- CVE-2022-51022YiShaAdmin 2.2 through 3.1, fixed in commit 025b062, contain…9.1
- CVE-2022-51023PHPOK 4.5.000 before 5.4.081 contains an SQL injection vulne…8.2
- CVE-2022-51024Kavita 0.5.2 before 0.5.4.1 contains a path traversal vulner…7.5
- CVE-2022-51026Bytebase 0.12.0 before 1.0.1 contains an authentication bypa…9.8
Are you affected by CVE-2022-51025?
Run a free Strix scan to check your systems for this vulnerability.
Scan your code nowSource: NVD / NIST
