CVE-2022-51026
Last modified
CVE-2022-51026 is a critical-severity vulnerability rated 9.8/10 on the CVSS scale. Bytebase 0.12.0 before 1.0.1 contains an authentication bypass vulnerability that allows unauthenticated attackers to log in as any user. The flaw stems from trusting client-supplied GitLab provider configuration in the POST /api/auth/login/GITLAB_SELF_HOST endpoint. EPSS estimates a 0.61% chance of exploitation in the next 30 days.
Description
Bytebase 0.12.0 before 1.0.1 contains an authentication bypass vulnerability that allows unauthenticated attackers to log in as any user. The flaw stems from trusting client-supplied GitLab provider configuration in the POST /api/auth/login/GITLAB_SELF_HOST endpoint. Attackers can set instanceUrl to a server they control that returns an active user with a chosen email. Bytebase then issues session tokens for that principal, letting attackers impersonate existing users including the Owner or create new members.
Metrics
Weakness Enumeration
Affected Software
Source: CNA advisory (CVE.org). NVD analysis pending.
| Vendor | Product | Versions |
|---|---|---|
| bytebase | bytebase | >= 0.12.0, < 1.0.1 |
References
Timeline
- Published
- Last Modified
- Status
- Deferred
Frequently Asked Questions
What is CVE-2022-51026?
How severe is CVE-2022-51026?
How do I fix CVE-2022-51026?
How Strix Helps
- Same Subject, Wrong User: A Cross-Issuer Account Takeover in n8nStrix found an identity-binding bug in n8n's token-exchange flow enabling account takeover.
- Autonomous PentestingAI agents that find and validate exploitable vulnerabilities like this one across your applications.
- PR ReviewsPentest every pull request so vulnerable code is caught before it ships to production.
- AI Penetration TestingHow AI-driven penetration testing continuously covers your attack surface.
Related CVEs from 2022
- CVE-2022-51020Flower before 2.2.0 contains a cross-site request forgery vu…5.9
- CVE-2022-51021NotificationX plugin for WordPress 2.0.0 before 2.3.12 conta…8.2
- CVE-2022-51022YiShaAdmin 2.2 through 3.1, fixed in commit 025b062, contain…9.1
- CVE-2022-51023PHPOK 4.5.000 before 5.4.081 contains an SQL injection vulne…8.2
- CVE-2022-51024Kavita 0.5.2 before 0.5.4.1 contains a path traversal vulner…7.5
- CVE-2022-51025Penta Security WAPPLES 4.0.54.1, 5.0, and 6.0 contains a pat…6.5
Are you affected by CVE-2022-51026?
Run a free Strix scan to check your systems for this vulnerability.
Scan your code nowSource: NVD / NIST
